5 posts by 3 authors in: Forums > CMS Builder
Last Post: March 24, 2014   (RSS)

This is odd, but I cannot view the WYSIWYG editor with any system setup or browser combo on two v2.60 installs. I've even viewed using a remote testing service, so I know it's not a local caching issue.

(see screenshot attached)

Does anyone else have this happening?

~ Deborah

Attachments:

02-18-14-11-03-27-am.jpg 47K

Hi Debora,

Thanks for bringing this to our attention. Which browser are you using? Would you mind filling out a second level support request for me? You can find the form here:

https://www.interactivetools.com/support/email_support_form.php

Then I can take a closer look at what is causing the issue.

Thanks!

Greg

Greg Thomas
PHP Programmer - interactivetools.com

By Djulia - March 21, 2014

Hi Greg,

I have a customer who has the same problem.

It is difficult to find the origin, because I am not able to reproduce this behavior on our work stations.

It uses a proxy server, it is perhaps the origin.

Do you have a beginning of response?

Thanks!

Djulia

Hi Djulia, 

The most likely issues is that wysiwyg content is being gzipped twice. It could well be that the proxy server is gzipping the content again before it's sent to the workstations. 

The best way around this is to disabled the gzipping feature, you'll have to make a change to the CMS Builder core code to get this working.

If you open cmsAdmin/3rdParty/tiny_mce/tiny_mce_gzip.php, around line 213 you should see this line:

    $supportsGzip = $this->settings['compress'] && !empty($encoding) && !$zlibOn && function_exists('gzencode');

if you change it to this:

    $supportsGzip = false;

This will ensure that gzip isn't used to shrink the WYSIWYG content, and should stop the issue from happening.

If this doesn't work, you can fill out a second level support request here:

https://www.interactivetools.com/support/email_support_form.php

Then I'll take a closer look into the issue. 

Thanks!

Greg

Greg Thomas
PHP Programmer - interactivetools.com