CMSB v3.54 Released - October 29, 2020

27 posts by 9 authors in: Forums > CMS Builder
Last Post: February 23, 2021   (RSS)

  • Archived  

By Dave - November 10, 2020

Hi Steve,

Thanks for the report.  Can you provide a bit more details about what exactly is happening?  I wasn't totally clear from your post.  Thanks!

Dave Edis - Senior Developer
interactivetools.com

Error on Category Menu?

  • Archived  

By hiroko - November 11, 2020

Hi,

I might be missing something, but I have a list field that I have been doing the same thing in older versions that don't seem to work now.

I'm using "Get options from MYSQL query" and when I use the WHERE query, I get "There was an error sending the request! (403 error)" and cannot save.

SELECT num, name
FROM `<?php echo $TABLE_PREFIX ?>json_ld_properties`
WHERE markup_type = '<?php echo $ESCAPED_FILTER_VALUE;?>type2'

When I get rid of the WHERE, it works.

Is there any changes I should make?

Thanks in advance,

Hiroko

Error on Category Menu?

  • Archived  

By hiroko - November 20, 2020

Hi,

I finally found out why my "Get options from MYSQL query" setting couldn't be saved.

The server had a WAF setting (Web Application Firewall) that detects access to SQL statements. I turned it off, and I was able to save.

There was also a WAF setting that detects 'kill, ftp, mail, ping, ls' commands that will case 501 error on saving record for Newsletter Builder.

Sorry if I took your time. 

In case someone has the same problem, you might want to check the server settings.

Best,

Hiroko

challenge with CMSB v3.54 Released - October 29, 2020

  • Archived  

By Codee - November 20, 2020

Hi Dave,

I posted a question/suggestion on this same thread on October 30. I do not see a reply and am hoping for an answer on that referenced error flag being thrown because CMSB may not be recognizing equality between versions of MySQL and MariaDB...if my neophyte brain understands this correctly. 

Thank you kindly.

challenge with CMSB v3.54 Released - October 29, 2020

  • Archived  

By Toledoh - November 20, 2020

Ive got the same issue with Maria DB showing an alert  

Cheers,
Tim (toledoh.com.au)

challenge with CMSB v3.54 Released - October 29, 2020

  • Archived  

By Dave - November 23, 2020

Hi Guys, 

The MariaDB error can safely be ignored for now.  We're going to update that for the next release.  It's because the MySQL and MariaDB version numbers don't match up.

You can comment out that error for now if needed or just ignore it.  Let me know if you need a patch and I'll point you to the file and line.

Dave Edis - Senior Developer
interactivetools.com

challenge with CMSB v3.54 Released - October 29, 2020

  • Archived  

By Codee - November 23, 2020

Thanks Dave!

Which file and line? 

  • Archived  

By pault - November 30, 2020

I've just updated a site from v3.53 to v3.54.  It has background tasks running, set to run every minutes.

I've noticed that each time it runs, it's changing the 'localhost' value in settings.dat.php to be '127.0.0.1' (see line 56 of database_functions.php) which breaks the connection on this site.  I'm not sure why 127.0.0.1 isn't working on the server but I've had to comment this line out to prevent it from breaking as soon as I change the setting back.

Is there a reason why it's trying to update 'localhost' to '127.0.0.1'?

Thanks, Paul.

  • Archived  

By Dave - December 1, 2020

Hi Paul, 

Yea, it was a workaround to fix an issue where some linux servers couldn't connect to mysql with ssl enabled with localhost as the hostname.  

When you ping localhost on your server what IP is it returning? 

Dave Edis - Senior Developer
interactivetools.com