Hi Karls, 

No, Most of the API calls we use for Facebook Login are very standard and don't change much.  

Also, as I recall if you specify a version lower than they support they just give you the oldest API version they do support.

And lastly, the latest version of Facebook Login defaults to the 2.9 API, but it should be fine whichever version you are on.
https://www.interactivetools.com/add-ons/facebook-login/

Hope that helps!

Dave Edis - Senior Developer
interactivetools.com

Thank you Dave!