Error 2038 upon uploads - realize related to security issue, need immediate help if possible

11 posts by 6 authors in: Forums > CMS Builder
Last Post: March 9, 2017   (RSS)

By Codee - February 10, 2017


A new site, shared hosting, security protocols in place...including using https://  The site was working fine and suddenly I now get this Error 2038 upon trying to upload a graphic/photo.  I found this thread, but it was archived and no solution seemed present in the text:

My browser is FF 51.0.1, win xp sp 3,

Thank you in advance.

By Deborah - February 13, 2017

Hi, equinox.

A client of mine using version 2.65 experienced this error with Firefox last week. I couldn't replicate it in Firefox myself, but after some Internet searching provided some suggestions. I haven't heard back as to whether any of my suggestions worked, but will post again if I hear back from them.

You might try...

1) Update Firefox to the most current version.

 2) Make sure the website is listed in “security exceptions”. I saw mention that if the SSL is “self-signed”, this could case security issues in some versions of Firefox.

 3) Add the domain to the list of Allowed Sites in Firefox.

 4) Then close the CMS, clear all temporary files and cookies from Firefox, close Firefox, then restart everything and try again.

5) If still no success after the above, try disabling the Adobe Flash plugin in Firefox.

~ Deborah

By Codee - February 13, 2017

Thanks for posting back, Deborah...I appreciate it.

I've determined this IS a Firefox-based issue.  Did the steps you mentioned, in fact; but the only fix thus far, for FF, is to disable the flash uploader.  No problem in Chrome or IE.

By Codee - February 14, 2017

Hi Ross,

It's a fresh install, and yes, it's version 3.07.

By Dave - February 15, 2017

Hi equinox, 

Are you using a self-signed ssl certificate? See:

And how large is the file you are uploading? 

Dave Edis - Senior Developer

By Codee - February 16, 2017

Hi Dave,

I'm fairly certain it is a self-signed certificate. How can I check/tell for sure?

The challenge occurs, for me, regardless of the file sizes...testing with either .5mb up to 5mb. Same thing.  Turning off the Flash uploader and uploading (any size) images works fine on-at-a -time.  Turning Flash uploader back on and problem occurs - reproducible every time.

Thanks for the guidance.

By Dave - February 16, 2017

Ok, let's test if it's related to the SSL certificate. Does it work when you connect to the site via a http:// url and not a https:// url? 

Dave Edis - Senior Developer

By Deborah - February 16, 2017

You could try this SSL checker:

If the certificate is self-signed, it should show in the test results as "The certificate is self-signed. Users will receive a warning when accessing this site unless the certificate is manually added as a trusted certificate to their web browser."

And I think that if the "issuer" of the cert is the same as the domain itself, then it is self-signed.

By pacolvin - March 6, 2017

I'm having the same problem.  I recently installed a Let's Encrypt SSL certificate on a shared hosting site and get the same error when using the Flash Uploader.  Works fine in Chrome.

I checked the cert on and all is fine.  It is not self signed.

It is clearly related to flash and FF. 

Any chance there are plans to go away from the Flash uploader in the future?

Phil Colvin