11 posts by 6 authors in: Forums > CMS Builder
Last Post: March 9, 2017   (RSS)


A new site, shared hosting, security protocols in place...including using https://  The site was working fine and suddenly I now get this Error 2038 upon trying to upload a graphic/photo.  I found this thread, but it was archived and no solution seemed present in the text:


My browser is FF 51.0.1, win xp sp 3,

Thank you in advance.

Hi, equinox.

A client of mine using version 2.65 experienced this error with Firefox last week. I couldn't replicate it in Firefox myself, but after some Internet searching provided some suggestions. I haven't heard back as to whether any of my suggestions worked, but will post again if I hear back from them.

You might try...

1) Update Firefox to the most current version.

 2) Make sure the website is listed in “security exceptions”. I saw mention that if the SSL is “self-signed”, this could case security issues in some versions of Firefox.

 3) Add the domain to the list of Allowed Sites in Firefox.

 4) Then close the CMS, clear all temporary files and cookies from Firefox, close Firefox, then restart everything and try again.

5) If still no success after the above, try disabling the Adobe Flash plugin in Firefox.

~ Deborah

Thanks for posting back, Deborah...I appreciate it.

I've determined this IS a Firefox-based issue.  Did the steps you mentioned, in fact; but the only fix thus far, for FF, is to disable the flash uploader.  No problem in Chrome or IE.

By ross - February 14, 2017

Hi equinox

What version of CMS Builder are you getting the error in?

If you aren't already using the latest version, are you able to install a test version of CMS Builder 3.07 on your server?

Let me know if that helps.


Ross Fairbairn - Consulting

Hire me! Save time by getting our experts to help with your project.
Template changes, advanced features, full integration, whatever you
need. Whether you need one hour or fifty, get it done fast with
Priority Consulting: http://www.interactivetools.com/consulting/

Hi Ross,

It's a fresh install, and yes, it's version 3.07.

By Dave - February 15, 2017

Hi equinox, 

Are you using a self-signed ssl certificate? See: https://bugzilla.mozilla.org/show_bug.cgi?id=422180

And how large is the file you are uploading? 

Dave Edis - Senior Developer

By Dave - February 16, 2017

Ok, let's test if it's related to the SSL certificate. Does it work when you connect to the site via a http:// url and not a https:// url? 

Dave Edis - Senior Developer

You could try this SSL checker:

If the certificate is self-signed, it should show in the test results as "The certificate is self-signed. Users will receive a warning when accessing this site unless the certificate is manually added as a trusted certificate to their web browser."

And I think that if the "issuer" of the cert is the same as the domain itself, then it is self-signed.

I'm having the same problem.  I recently installed a Let's Encrypt SSL certificate on a shared hosting site and get the same error when using the Flash Uploader.  Works fine in Chrome.

I checked the cert on https://www.sslshopper.com/ssl-checker.html and all is fine.  It is not self signed.

It is clearly related to flash and FF. 

Any chance there are plans to go away from the Flash uploader in the future?

Phil Colvin