Login | Sign up | Toll-Free: 1-800-752-0455



7 posts by 4 authors in: Forums > CMS Builder
Last Post: October 26, 2016

By kkegans - October 25, 2016 - edited: October 25, 2016

I have seen this same issue since my Firefox was updated to v 49.0.2.

Backing down to Firefox 48.0.2 corrected the issue, so it seems that the latest Firefox is not compatible with the CMSB code for the Flash uploader.

CMSB Rocks!



We've also experienced the same thing in firefox only. It seems as if the wmode transparent parameter isn't working properly in latest firefox.

Hi everyone,

Yes, the issue of the missing upload link is caused by the latest version of Firefox (49.0.2).

Asynchronous rendering of the Flash plugins is now enabled by default. This is causing problems with "broken content including video players and games".

The article also has an update to suggest that asynchronous rendering will be disabled in the next version of Firefox and has been already for Firefox 50 Beta.

Here are some options while the Firefox issue is sorted out to show the upload link in CMS Builder:

1. Disable the flash uploader in CMS Builder. This will still all uploads but only one at a time.

In CMS Builder go to Admin > General Settings, then scroll down to Advanced Settings part of the page.
Check the File Uploads checkbox to "Disable Flash Uploader - attach one file at a time (doesn't require flash)" and click the Save button.

2. Have users use an alternate browser to Firefox:
Chrome, MS Edge, Safari, Opera

3. Change settings in Firefox:

Enter this is the browser address bar:

Search for dom.ipc.plugins.asyncdrawing.enabled

Toggle the Value from True to False

We will keep watching for updates from Firefox and post again when that is available.


Damon Edis

Hire me! Save time by getting our experts to help with your project.

Dave and Team,

Is this something you can look into?

Thanks Damon. I changed the FF config value, works like a charm.


Hi Damon,

Thanks!  I REALLY don't want my clients switching to browsers that don't run as stable, fast and safe as Firefox; and I don't want to turn off the flash uploader unless necessary. I tried a portion of your suggestions, just the part about changing the settings in Firefox. I'm running FF 49.0.2 and changing the settings (so far) has corrected the issue.