6 posts by 2 authors in: Forums > CMS Builder
Last Post: May 24   (RSS)

Having trouble with a new installation. Initially I was getting Internal Server Errors when I tried to load the install page. I was able to get past that by removing the php.ini file, but that only got me a little bit further. Now I am getting "Warning: session_start(): ... " messages. Not sure how to resolve this. Any suggestions?

Hey Zip,

Please, could you post the full session start_error message that's being displayed. Also, which version of CMS Builder are you attempting to install?

Regarding the issue with your PHP ini file, which internal server error message is displayed when it's present? I'd recommend adding it back to the CMS and contacting your hosting service and ask them what's causing the issue.

Greg Thomas
PHP Programmer - interactivetools.com

Without the php.ini file, this is the error message I get:

Warning: session_start(): open(/var/php_sessions/sess_hi98lssup789nop78anrimuosrfnia70, O_RDWR) failed: No such file or directory (2) in /hermes/bosnaweb19a/b1688/ipg.summerfieldfoundatio/cmsb/lib/init.php on line 733 Warning: session_start(): Failed to read session data: files (path: /var/php_sessions) in /hermes/bosnaweb19a/b1688/ipg.summerfieldfoundatio/cmsb/lib/init.php on line 733 Fatal error: Couldn't start session! ''! in /hermes/bosnaweb19a/b1688/ipg.summerfieldfoundatio/cmsb/lib/init.php on line 733

The CMS version is 3.51

With the php.ini, this is the error returned:

500 Internal Server Error

it displayed a slightly different error, and it also showed the Script complete message. Just submitted the second level support request.

Hey Everyone, 

I thought I'd follow up with the solution Zip222 used to resolve this issue. He updated his CMS Builder settings.dat.php file and added a custom path to store the session data. Here is an example of how you'd do that:

'advanced' => array(
    'imageResizeQuality' => '80',
    'showExpandedMenu' => '0',
    'disableFlashUploader' => '0',
    'codeGeneratorExpertMode' => '0',
    'hideLanguageSettings' => '0',
    'session_cookie_domain' => '',
    'session_save_path' => '/path/to/session/directory/',
    'requireHTTPS' => '0',
    'httpProxyServer' => '',
    'allowRelatedRecordsDragSorting' => '0',
    'outgoingMail' => 'logOnly',

So you'd replace the session_save_path variable '/path/to/session/directory/' with the full directory path to the location you want to store the session data on your web server. You should add the directory to store the session data outside of your public web directory if possible. If it has to be inside of your public web directory, add a .htaccess that denies all requests to it and ensure it has a name that could not be guessed.

Thanks,

Greg

Greg Thomas
PHP Programmer - interactivetools.com