8 posts by 3 authors in: Forums > CMS Builder
Last Post: April 17   (RSS)

By netsoftservices - April 11 - edited: April 12

I just upgraded to CMS Builder v3.51 (Build 2244). Disable Autocomplete is turned on in General settings, but no element attribute for autocomplete added to the admin/editor for fields.

Is there some other setting that I need to set?

Thank you!

Anyone?

Hey netsoftservices,

CMS Builder doesn't add the autocomplete tag to individual fields as its added to the form tag instead. Are you having issues with forms being autocompleted when they shouldn't be?

Unchecking the 'Disable Autocomplete' field in the General Settings attempts to disable the autocomplete on the login and password reset pages, but doesn't have any effect on the pages in the inside of the CMS were autocomplete is always disabled.

Thanks,

Greg

Greg Thomas















PHP Programmer - interactivetools.com

Hi Greg,

I guess I'm not entirely clear.

Does that hold for form tags on pages that we create, or only to forms built into CMSB and plugins?

Thanks,

Jerry Kornbluth

The first CMS Builder reference book is now available on-line!
Take advantage of a free 3 month trial subscription, only for CMSB users, at: http://www.thecmsbcookbook.com/trial.php

Hi Greg,

Yes. I am getting issues *inside* the CMS admin pages. Chrome is holding onto auto-complete on certain fields and pre-populating them. It is messing up my clients. They don't want to have to go and turn off autocomplete.

It would be great to be able to create a plugin that adds the autocomplete="off" attribute to EVERY input/select/etc in the CMSB backend. 

I may look into that, but I was assuming 'Disable Autocomplete' would do that based on the information next to the checkbox in General Settings.

Thanks for your input.

By gregThomas - April 15 - edited: April 15

Hey Everyone,

Jerry, this only holds for all forms inside of the CMS (for example, login pages, section/creation edit and pages, etc). But any forms created on the front end of the site by you, even when using the code generator, you'll need to add the tag yourself. You can read about how to use the autocomplete tag here:

https://www.w3schools.com/tags/att_input_autocomplete.asp 


netsoftservices, thanks for the extra details. The main issue is that Chrome now ignores the tag and will always attempt to autocomplete a form, we've added some HTML that tries to force Chrome to disable it in the new release, but it looks like it's not working for your client. I'll pass this issue on to our senior developer, do you know which OS your client is using and if they have the latest version of Chrome? It would also be helpful if you could give us an example of a CMS Builder page the issue happens on.

Greg Thomas















PHP Programmer - interactivetools.com

By netsoftservices - April 15 - edited: April 15

Hi Greg,

Thanks so much for that. Yes, I can recreate it with Chrome Version 73.0.3683.103 (Official Build) (64-bit) on a Mac.

One of the fields that is giving me trouble in an editor page is a field named youtube_id. I created a textfield named 'YouTube ID'. I use it to store a video ID, but I guess it seems to match up with maybe the youtube login page as well and Chrome tries to prepopulate it with an email address.

If you need more details, I can email you all screen caps.

Thanks again.

[edit] - make sure you store your CMSB admin login info when signing in to CMSB. It actually seems to try to copy over the admin 'username' into that editor field. At least on my machines.

Hey netsoftservices, 

Thanks for those extra details, I've tried recreating the issue on MacOS on the same version of Chrome, but wasn't able too.

It would be great if you could send us those example screenshots, please could you email them to support@interactivetools.com? It would be great if you could include the URL to the CMS that's affected along with a username/password I can test with, if that's possible.

Cheers,

Greg Thomas















PHP Programmer - interactivetools.com