2 posts by 2 authors in: Forums > CMS Builder
Last Post: June 22, 2018   (RSS)

By zaba - June 22, 2018

I am trying to install the pdf generator plugin but having issues with the server reqs when testing.

its on a shared server so unable to install anything. I have sent an email to dave, but just thought id post her in case he didn't get the email for some reason.


PDF Conversion Program
This plugin is using: /XXXXXXXXXX/cmsb/plugins/createPDF/wkhtmltopdf/wkhtmltopdf-0.12.4_linux-generic-amd64
Plugins settings: CREATEPDF_BINARY_FILE: auto-detected
If all the test below don't pass you can try: download updated binaries and testing all binaries
Passed! Run external program on server
Testing shell_exec() with command: pwd
Result: /XXXXXXXXXX/cmsb
Failed! Test running PDF conversion program on server
Testing pdf binary with command: /XXXXXXXXXX/cmsb/plugins/createPDF/wkhtmltopdf/wkhtmltopdf-0.12.4_linux-generic-amd64 -V
Result: 0 bytes returned
Output:
Error: No output returned from command! (Exit code: 1)
Passed! Create and remove temp file on server
Creating temp file: /XXXXXXXXXX/cmsb/createPDF_e3fb0137ddc520aacaa14f3c26561f50.tmp
Removing temp file: /XXXXXXXXXX/cmsb/createPDF_e3fb0137ddc520aacaa14f3c26561f50.tmp
Passed! Test downloading content from remote URL
Downloading content from url with: getPage('http://www.google.com/');
Result: HTTP status code 302 (view source, html)
Failed! Test downloading content from this server
Downloading content from url with: getPage('http://xxxxxxx/');
Resolve hostname 'xxxxx' to IP address: xxx.xxx.xxx.xxx
Error: Received HTTP status code '301' (should be 200 or 302)! (view source, html)
The following shell commands may help you debug connection issues from your server:
wget --spider -T2 -O- http://xxxxxxx/ 2>&1
curl --head -v -m2 http://xxxxxx/ 2>&1
Failed! Test converting a web page to a PDF
Created PDF with: HTML from: https://www.google.com/
Result: 0 byte PDF returned
Error: Conversion program returned errors:
/XXXXXXXXXX/cmsb/plugins/createPDF/wkhtmltopdf/wkhtmltopdf-0.12.4_linux-generic-amd64: /lib64/libc.so.6: version `GLIBC_2.9' not found (required by /XXXXXXXXXX/cmsb/plugins/createPDF/wkhtmltopdf/wkhtmltopdf-0.12.4_linux-generic-amd64) /XXXXXXXXXX/cmsb/plugins/createPDF/wkhtmltopdf/wkhtmltopdf-0.12.4_linux-generic-amd64: /lib64/libc.so.6: version `GLIBC_2.10' not found (required by /XXXXXXXXXX/cmsb/plugins/createPDF/wkhtmltopdf/wkhtmltopdf-0.12.4_linux-generic-amd64) /XXXXXXXXXX/cmsb/plugins/createPDF/wkhtmltopdf/wkhtmltopdf-0.12.4_linux-generic-amd64: /lib64/libc.so.6: version `GLIBC_2.7' not found (required by /XXXXXXXXXX/cmsb/plugins/createPDF/wkhtmltopdf/wkhtmltopdf-0.12.4_linux-generic-amd64) Error executing wkhtmltopdf! (Exit code: 1)

Visually review PDF output (link)
Visually inspect the PDF below, correct any error message, then make sure the graphics and fonts display as expected: