Bug: disable auto-fixes for logins

5 posts by 4 authors in: Forums > CMS Builder
Last Post: March 6, 2017   (RSS)

By ross - February 22, 2017

Hi mizrahi

Thanks for the link.

I had a read through and think I get what they are aiming at with the auto capitalization in form fields. I like the idea as it's something I've noticed quite a bit too.

Is there anything else you'd like me to do with this post?  

My thoughts are you are providing it to the community for other developers to include in their projects.

Let me know if I am missing anything :).


Ross Fairbairn - Consulting

Hire me! Save time by getting our experts to help with your project.
Template changes, advanced features, full integration, whatever you
need. Whether you need one hour or fifty, get it done fast with
Priority Consulting: http://www.interactivetools.com/consulting/

By zip222 - February 22, 2017

Can you implement this on the login fields for CMS Builder?

By gregThomas - March 6, 2017

Hi Everyone, 

I've updated our code base so that auto correct and auto capitalization will be disabled on the login page username field in the next release of CMS Builder. If you want to add this feature to your current CMS Builder installation, you can update line 21 of login.php, which can be found in [cmsb directory]\lib\menus\login.php. The original line should look like this:

<input class="text-input" type="text" name="username" id="username" value="<?php echo htmlencode(@$_REQUEST['username']) ?>" tabindex="1" <?php disableAutocomplete(); ?>/>

You'll need to add the text highlighted in green to it:

<input class="text-input" type="text" name="username" id="username" value="<?php echo htmlencode(@$_REQUEST['username']) ?>" tabindex="1" autocorrect="off" autocapitalize="off" <?php disableAutocomplete(); ?>/>


Greg Thomas

PHP Programmer - interactivetools.com