17 posts by 6 authors in: Forums > CMS Builder
Last Post: December 29, 2012   (RSS)

By weblm - November 13, 2012

So I'm just reporting back that in the latest 2.17 this issue still exists.

In the General Settings section I have:

Upload Directory: uploads/
Upload Folder URL: /cmsAdmin/uploads/

In the record field for photos I have custom upload directories of:

Directory Path: properties/
Folder Url: /cmsAdmin/uploads/properties/


Again....this is working, however, it is still creating the properties empty folder at the cmsAdmin level (same level as the main uploads folder).

Any ideas?

-Kevin

Re: [Damon] Bug with custom upload directory?

I too have had this problem and it leaves me scratching my head also. I agree that if the prompt indicates that the path is relative to the base upload directory and the base upload directory is set properly to whatever/cmsAdmin/uploads/ that custom_folder/ is all that should be entered. If I do that, I get folders created in the root. I still have to append the custom folder to the full upload path to make it work.

I thought maybe, in my old age, I missed something but I now think it is not working as designed OR the instruction needs to be clarified.
Ron Conring
Conring Automation Services
----------------------------------------
Software for Business and Industry Since 1987

Re: [sublmnl] Bug with custom upload directory?

CMSBuilder 2.17

Using relative paths is still not working. As per the previous examples, I receive a message that the directory does not exist, althought it does.

------------

Jeff Shields

Re: [sublmnl] Bug with custom upload directory?

By Damon - December 27, 2012

Using relative paths is still not working. As per the previous examples, I receive a message that the directory does not exist, althought it does.

If your custom upload directory is inside the uploads folder (example: /uploads/PDFs/) try using these settings for your custom upload directory:

Directory Path:  PDFs/
Folder URL:      PDFs/

*Change PDFs to what folder name you are using.

This works for me. Can you try this out and let me know if you have any issues?

---------------------------------------------------
Cheers,
Damon Edis - interactivetools.com

Hire me! Save time by getting our experts to help with your project.
http://www.interactivetools.com/consulting/

Re: [sublmnl] Bug with custom upload directory?

This is how it should be set:

General Settings:
Website Root Directory:  /home/lmdianet/public_html/mmp
Upload Directory : /home/lmdianet/public_html/mmp/cmsAdmin/uploads/
Upload Folder URL:  /cmsAdmin/uploads/

Property Uploads Field:
Directory Path: /home/lmdianet/public_html/mmp/cmsAdmin/uploads/properties/
Folder URL:  /cmsAdmin/uploads/properties/

Try that ... I think the problem is in the interpretation of the instructions that accompany the upload path fields.

Ron Conring
Conring Automation Services
----------------------------------------
Software for Business and Industry Since 1987

Re: [sublmnl] Bug with custom upload directory?

That would no longer make the paths relative, which would require changing the paths for each section when moving from development to staging to production. NOT acceptable solution.

Also seems in this thread we are getting confilicting instructions so something is definitely wrong here. The instructions are how it should work, but doesn't.

------------

Jeff Shields