Upload Feature Error

15 posts by 7 authors in: Forums > CMS Builder
Last Post: October 22, 2012   (RSS)

By beckstar - November 22, 2011

Dear CMS Builder Team,

I've been working with the tool for some time now and I've noticed that version 2.12 is disallowing the upload of .SWF file types. It returns the following error: File 'filename.swf' isn't a valid 'swf' file.

It does even when you specify swf in the File extensions allowed: field in the input validation.

Please assist as I have a great need to continue uploading swf file types via this method.

I've attached a copy of the screens in question. Also, I've tested this on more than one installations of the product with the same version.

Thanks in advance.

Ian
Attachments:

cms_builder_error.jpg 70K

Re: [beckstar] Upload Feature Error

By Damon - November 22, 2011

Hi Ian,

I was able to successfully upload a swf file using a test installation of CMS Builder 2.12.

Can you try uploading a different swf file to test?

Send in a 2nd Level Support Request so I can take a look:
https://www.interactivetools.com/support/email_support_form.php

Reference this forum post URL in the ticket.

Thanks!
Cheers,
Damon Edis - interactivetools.com

Hire me! Save time by getting our experts to help with your project.
http://www.interactivetools.com/consulting/

Re: [beckstar] Upload Feature Error

By rconring - November 23, 2011

You need to separate the file extensions with COMMAS not DOTS. eg: jpg,swf,png
Ron Conring
Conring Automation Services
----------------------------------------
Software for Business and Industry Since 1987

Re: [rconring] Upload Feature Error

By beckstar - November 23, 2011

Thanks rconring, but I used commas, the JPEG may look like dots but they are commas.

Re: [beckstar] Upload Feature Error

By rconring - November 23, 2011

Yes, they are dots in the jpeg ... are there any spaces? I almost went nuts trying to find the problem when that happened to me ... turns out I had a space in front of the extension.
Ron Conring
Conring Automation Services
----------------------------------------
Software for Business and Industry Since 1987

Re: [beckstar] Upload Feature Error

By Damon - November 23, 2011

Hi,

If there are no spaces and you are using commas top separate the allowed files types, send in a support request and I would be happy to look into it.

Thanks!
Cheers,
Damon Edis - interactivetools.com

Hire me! Save time by getting our experts to help with your project.
http://www.interactivetools.com/consulting/

Re: [Damon] Upload Feature Error

By Djulia - September 28, 2012 - edited: September 28, 2012

Hi,

I have the same problem.

But, I also obtain an error : Undefined index: channels in upload_functions.php on line 201

Is there a solution?

Thanks!

Djulia

Re: [Jason] Upload Feature Error

By Djulia - October 2, 2012

Hi Jason,

It is with version 2.17.

The problem occurs when a file .SWF is uploaded.

An idea?

Thanks!

Djulia

Re: [Djulia] Upload Feature Error

By Jason - October 3, 2012

Hi Djulia,

Is it always the same swf file? Can other files be uploaded correctly?

If you could send in a [url http://www.interactivetools.com/support]2nd Level Support[/url] Request and let us know which section the error occurs in, we can take a look. If you could also provide the swf file you are trying to upload, that would help as well.

Thanks
---------------------------------------------------
Jason Sauchuk - Project Manager
interactivetools.com

Hire me! Save time by getting our experts to help with your project.
http://www.interactivetools.com/consulting/