GeoCoder

4 posts by 2 authors in: Forums > CMS Builder: Plugins & Add-ons
Last Post: September 3   (RSS)

By pgplast - September 2

I have recently insralled Geocoder on a site to do some testing as we develop. (v.1.09)

I created a Google account with crediot card, created an API key and enabled all the Map related APIs.

(I have restricted to key to the one domain I am setting up.)

I have set the $GLOBALS['GEOCODER_GOOGLE_API_KEY'] = 'My-API-Key' and activated the plugin in CMSB.

When I run the test I get:

Attempting to geocode address '1600 Pennsylvania Ave NW, Washington, DC 20500, USA'...Geocoder errors: STATUS_REQUEST_DENIED

Google, it seems, is denying the request. Am I missing something alse in the setup?

Thanks.

By Dave - September 2

Hi pgplast, 

We're working on an update to that plugin to potentially provide better error reporting but in the meantime try this query in your browser:

https://maps.googleapis.com/maps/api/geocode/json?address=Vancouver&key=[YOUR_API_KEY]

It should return a JSON error message with more details.  For example, when I tried with an old key I hadn't used in a while it reported this: 

{
   "error_message" : "You must enable Billing on the Google Cloud Project at https://console.cloud.google.com/project/_/billing/enable Learn more at https://developers.google.com/maps/gmp-get-started",
   "results" : [],
   "status" : "REQUEST_DENIED"
}

Let me know if you find it what it is, I'm curious!  

Good luck!

Dave Edis - Senior Developer
interactivetools.com

By pgplast - September 3

Dave:

Thanks so  much for that. The response revealed that the restrictions I put on the key were the thing.

I removed them and now it is working. It seems that restricting to one doamin causes a problem. Oh well.

Thanks for your help.

By Dave - September 3

Ok, great.  Glad it's working and thanks for letting us know. 

Dave Edis - Senior Developer
interactivetools.com