Apache CVE-2019-0211 Vulnerability Detection Script
|Name:||Apache CVE-2019-0211 Vulnerability Detection Script|
|Version:||1.0 (Released May 6, 2019)|
|Requirements:||Apache HTTP Server, PHP 5.6+|
On April 1st, 2019 it was discovered that over 2 million Apache HTTP Servers were vulnerable to a security exploit known as CVE-2019-0211.
CVE-2019-0211 allows anyone with an account on a server to potentially escalate their access and gain complete control of the server. Shared-hosting environments are particularly at risk because any single user could potentially gain control of the entire server to access and manipulate other users' websites. The vulnerability exists in versions 2.4.17 to 2.4.38 of Apache HTTP Server and was patched with the release of version 2.4.39.
We have created a script that can be uploaded to your web server and used to easily determine if your Apache HTTP Server is currently running an unpatched version. Simply download and unzip the ZIP file, upload the PHP script to your web server, and view it through your web browser.
Visit our community forum post for questions, comments, and additional discussion,