Login | Sign up | Toll-Free: 1-800-752-0455
 
 

Forum

 

13 posts by 4 authors in: Forums > CMS Builder
Last Post: March 7, 2018

Hi,

Is there any know conflict with cmsb v2.65 (Build 1122) and PHP v7?

My provider tried to upgrade PHP to v7 but reported back to me that my page/web-app stopped working and they changed back to v5.6.33.

Also I stopped getting notifications from the forum via emails.

Please advise,
Karls

Hi Karls,

I think it is the mysql deprecation error. Can try upgrade cmsb to version 3.12 and try upgrading php version?

Let me know if it works!

Thanks,

Leo - PHP Programmer (in training)
interactivetools.com

Hi Leo,

Thanks for you reply. It is very difficult to upgrade this site that running as a production web-app with many customization with add-ons like membership and facebook login.

Is there anything I can do to avoid these mysql deprecation errors?

Also please check my forum notification error, I never getting any emails when i getting a reply on any post. I sent an email also to support but no answer on this.

Thank you,
Karls

Hi Karls,

PHP has removed all mysql_ functions and replaced with mysqli. And I don't think there's easy way to create all mysql functions or replace the old functions with mysqli functions. Is there any particular reason why you would need PHP v7?

For the forum notifications are they in the spam folder?

Thanks,

Leo - PHP Programmer (in training)
interactivetools.com

Hi Karls,

I just noticed that in the newest version of cmsb under General Settings > Advanced Settings, there is a checkbox "Legacy MySQL Support" that adds the support to old mysql functions even if they are deprecated and removed.

In that case, I think you can also try backup the current cmsb and create a separate latest version of cmsb with all add-ons and legacy mysql support. Then test to see if the newest version works fine for you.

Let me know if this helps!

Thanks,

Leo - PHP Programmer (in training)
interactivetools.com

Hi Leo,

Definitely I'll give it a try, thanks for the tip!

About the forum notifications, I'm very sure that I didn't getting any email from the forum at all. I have control on my spam folder.
There is something on your side. Can you check for the email with ht1080z name in it please?

Thanks again,
Karls

Karls, 

Can you test if the password reset form sends you an email?  Note, you don't need to reset your password, but it's an easy way to send a test email.

https://www.interactivetools.com/add-ons/login_forgotPassword.php

Let me know, thanks!  

Dave Edis - Senior Developer
interactivetools.com

Hi Dave,

I did a request for password reset and got nothing by email.

Request sent: 18.02.2018 09:15 GMT+2
my shared IP:
IP v4: 94.64.94.240
IP v6: 2a02:587:a04:8a00:7d75:1647:aebf:9f40

Thank you,
Karls

Hi Karls,

I see the password reset email in the outgoing email log.

Do you have an alternate to hotmail email account you could use to test?

Then we could see if the issue may be specific to hotmail.

Please let me know.

Thanks!

---------------------------------------------------
Cheers,
Damon Edis
interactivetools.com

Hire me! Save time by getting our experts to help with your project.
http://www.interactivetools.com/consulting/

Hi Damon,

I sent a message to your email about this.

Karls