6 posts by 2 authors in: Forums > CMS Builder: Plugins & Add-ons
Last Post: May 14   (RSS)

I just recently purchased the Permalinks Plugin and I'm having an issue.

I added the 'permalink' field to  a section within our CMS. When I Update Tables I receive an error as follows:

12345 - couldn't determine permalink!

Have I missed a step during the setup or something else?

Thanks - nmsinc

nmsinc

Hey nmsinc,

I suspect the issue is that the section you're testing on doesn't have fields with either the name 'title' or 'name', so the permalinks plugin can't automatically generate a permalink for each record.

If this is the case, you can update line 11 of permalinks.php so that it has the field that the plugin should generate the permalink from:

$GLOBALS['PERMALINKS']['autopopulate_fromFields'] = array('name', 'title', 'your_field_here'); // the first field in this list with content will be used to create the permalinks. To use multiple fields separate them with spaces or slashes​

Let me know if this isn't the issue.

Thanks!

Greg Thomas
PHP Programmer - interactivetools.com

Hey nmsinc,

Have you added the permalinks .htaccess code to your site? If you have, can you let me know the error that's being displayed on your 404 page.

Greg Thomas
PHP Programmer - interactivetools.com

Hi Greg,

I have the .htaccess located in the main root directory (this is not the websites root though). When I locate it in the website root, I receive a ISR as listed below:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@aprnews.com to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

nmsinc

Hey nmsinc,

I suspect the issue is that the path to the permalinks dispatcher isn't correct in the htaccess file, this is the line to check:

RewriteRule . /cmsb/plugins/permalinks/permalinks_dispatcher.php [L]

You'll need to check that the path is correct and update it if it isn't.

If this isn't an issue, can you raise a second level support request here:

https://www.interactivetools.com/support/request/

So that I can take a closer look.

Thanks,

Greg Thomas
PHP Programmer - interactivetools.com