Geocoder feature suddenly stopped working

6 posts by 3 authors in: Forums > CMS Builder
Last Post: October 26, 2018   (RSS)

By CommonSenseDesign - October 25, 2018

Hi, there.

A client's site, which I worked on years ago, has a Geocoder search feature. For some reason, the search function has suddenly stopped working: http://mountainoakcheese.com/retailers-search.php. Neither I nor my client has made any changes, so I was wondering what would make this happen. Any ideas, please?

The retail listings page uses the same information that was input via CMSB, and that seems to be okay - http://mountainoakcheese.com/retailers.php?orderBy=title - so I think it's just the search function.

Thanks!

By gkornbluth - October 25, 2018 - edited: October 25, 2018

Hi,

You may have to sign up for a new google api key account.

Google has recently updated the terms and conditions for their API, now you have to have a credit card on file and an API key to be able to use the plugin.

You can see the changes here:

https://developers.google.com/maps/documentation/geocoding/usage-and-billing

https://developers.google.com/maps/billing/important-updates#product_changes

Unless you are heavily using their service, you will not see any change and the service will remain free. (they offer a $200/month credit against any charges)

hope that solves your issue. It did for me,

Best,

Jerry Kornbluth

The first CMS Builder reference book is now available on-line!

Take advantage of a free 3 month trial subscription, only for CMSB users, at: http://www.thecmsbcookbook.com/trial.php

By gregThomas - October 25, 2018

Hey,

Like Jerry said, Google has made a lot of changes to their Geocoder API recently. You now have to link an API key to the plugin, a payment method needs to be linked to that API key and you'll need to enable the Geocoder feature. I've just released a new version of the plugin that has more detailed notes on enabling the API. Here are the new notes:

GETTING STARTED
-------------------------------------------------------------------------------

First, if you're planning to display your geocoded addresses on a Google Map,
you'll need to get an API key. The steps to do this are below (Requires Google account):

* Visit https://developers.google.com/maps/documentation/geocoding/get-api-key
* Click 'Get Started'
* Select 'Maps' and click 'Continue'
* Click the dropdown to either select an existing project or create a new one, 'Next'
* Follow the steps to create/enable a billing account for this project.
* Accept the prompt to enable the Maps API.
* Copy the API key and paste it into the value for
$GLOBALS['GEOCODER_GOOGLE_API_KEY'], and click 'Done'
* The final step is to enable the Geocoding API.
* On the Projects homepage, select the APIs from the left hand menu.
* Click the Geocoding API link under the Unused APIs menu.
* When the Geocoding API detail page appears, click the 'Enable' button.
* (Optional) Click 'Secure Credentials'
* Under Application Restrictions, select HTTP Referrers
* Add the domain for the website(s) this API key will be used on (for example localhost,
example.com, 8.8.8.8)
* Click API restrictions
* Select the Geocoding API from the dropdown
* Click Save

I'd recommend upgrading to the latest version of the plugin, this should resolve the issues you're having.

Greg Thomas







PHP Programmer - interactivetools.com

By gkornbluth - October 25, 2018

Thanks for the update Greg,

I believe you need the new API Key account whether you are displaying map info or not when using the Geocoder Plugin

I had to do that on a Geocoder install that I am using in order to get the thing to work again.

Best,

Jerry

The first CMS Builder reference book is now available on-line!

Take advantage of a free 3 month trial subscription, only for CMSB users, at: http://www.thecmsbcookbook.com/trial.php

By CommonSenseDesign - October 26, 2018

Hi, Greg.

The Geocoder was originally set up for my client by Interactive Tools. Is this something you would be able to update for me, including the Google API?

Cheers.