Geocoder API Error

By gregThomas - September 28, 2018

Hey,

The most likely issue is that the Geocoder API hasn't been enabled for the API key. Google has recently changed their developer accounts so that this feature isn't enabled by default. This can be done by following these steps:

  • On the Projects homepage, click the Geocoding API link under the Unused APIs menu.
  • When the Geocoding API detail page appears, click the 'Enable' button.

If that doesn't work, I'm currently working on a new version of the Geocoder plugin that will give more detailed feedback on any errors. Please can you send an email to support@interactivetools.com with the FTP and CMS login details for the site that is affected. Then I'll install this new version to get a better idea of the cause.

The most common cause of this error is:

  • The plugin doesn't have an API key added to it.
  • The Geocoder API hasn't been enabled.
  • Security restrictions have been added to the key that stop it from working.

Cheers,

Greg

Greg Thomas

PHP Programmer - interactivetools.com

By theclicklab - September 28, 2018

Hi Greg, OK great thanks, that fixed it... That was really hard to find where to enable the API!

By gregThomas - September 28, 2018

Great! I agree, that interface is a maze. We'll be releasing a new version of the plugin soon with updated instructions on how to setup the plugin.

Greg Thomas

PHP Programmer - interactivetools.com