Forbidden - You don't have permission to access /cmsAdmin/plugins/createPDF/examples/_createPDF_temp on this server

6 posts by 2 authors in: Forums > CMS Builder: Plugins & Add-ons
Last Post: March 6, 2018   (RSS)

By nmsinc - March 5, 2018

Everything was working just fine on this server when generating PDF files via the PDF generator until today. I'm now getting the following error message:


You don't have permission to access

/cmsAdmin/plugins/createPDF/examples/_createPDF_temp_aba1fecf2600315e9a95d02663e80011.html on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

The url code works just fine, but the HTML and page generation tags are all giving this message even on the test pages generated form the CMS side!

Any help would be appreciated!


By Dave - March 5, 2018

Hi nmsinc, 

It may be related to the permissions on that folder or the parent folders.

If you create a test.html file in /cmsAdmin/plugins/createPDF/examples/test.html are you able to view that through the browser?

And are the temp files left there?  And if so do they have different permissions then your test file?

Let me know what you find out.

Dave Edis - Senior Developer

By nmsinc - March 5, 2018 - edited: March 5, 2018

I tested it across all pages in the home directory that can be seen by everyone and I'm getting the same error. I tried using the URL code below:



$data = createPDF_fromUrl($url);

createPDF_display('attachment', $data,'example.pdf');


When used I receive the following page error:

Error: Failed loading page http:/directory/detail_download_pdf.php?num=1 (sometimes it will work just to ignore this error with --ignore-load-errors)


By nmsinc - March 6, 2018

I updated to CreatePDF version 1.07 and tested within the CMS with following message:

PDF Conversion ProgramThis plugin is using: /home/directory/public_html/cmsAdmin/plugins/createPDF2016/wkhtmltopdf/wkhtmltopdf-0.12.3_linux-generic-amd64
Plugins settings: CREATEPDF_BINARY_FILE: auto-detected
If all the test below don't pass you can try: download updated binaries and testing all binaries

  • Passed! Run external program on serverTesting shell_exec() with command: pwd
    Result: /home/claimsca/public_html/cmsAdmin
  • Passed! Test running PDF conversion program on serverTesting pdf binary with command: /home/claimsca/public_html/cmsAdmin/plugins/createPDF2016/wkhtmltopdf/wkhtmltopdf-0.12.3_linux-generic-amd64 -V
    Result: 36 bytes returned
    Output: wkhtmltopdf 0.12.3 (with patched qt)
  • Passed! Create and remove temp file on serverCreating temp file: /home/claimsca/public_html/cmsAdmin/createPDF_547a07a5364cefa311fb1132527a8702.tmp
    Removing temp file: /home/claimsca/public_html/cmsAdmin/createPDF_547a07a5364cefa311fb1132527a8702.tmp
  • Passed! Test downloading content from remote URLDownloading content from url with: getPage('');
    Result: HTTP status code 302 (view source, html)
  • Passed! Test downloading content from this serverDownloading content from url with: getPage('');
    Resolve hostname '' to IP address:
    Result: HTTP status code 403 (view source, html)
    Check that this is returning your website's homepage!
  • Passed! Test converting a web page to a PDFCreated PDF with: HTML from:
    Result: 25031 byte PDF returned
  • Visually review PDF output (link)Visually inspect the PDF below, correct any error message, then make sure the graphics and fonts display as expected:

END OF TEST--------------------------------

HOWEVER: when run the [ Plugins > Create PDF - Example Code ] across ALL "inline" and "attachment" code tests I get this error:

Exit with code 1 due to network error: ContentOperationNotPermittedError Error executing wkhtmltopdf! (Exit code: 1)<br/>

I also tested pages using all example code on pages within the "home" directory and received the same error across the board!

Any suggestions?




By Dave - March 6, 2018

Hi nmsinc, 

Can you send server login details and a link to this thread to and I can debug it for you?  Note, don't post login details to the forum.


Dave Edis - Senior Developer