Login | Sign up | Toll-Free: 1-800-752-0455
 
 

Forum

 

7 posts by 3 authors in: Forums > CMS Builder
Last Post: December 22, 2017

Hello! 

I was trying to upgrade from v3.08 (build 2120) to v3.11. After uploading/replacing the cmsb folder and then attempting to go to the admin.php page, I get this browser error: 

mysqli: error setting character set utf8mb4: Can't initialize character set utf8mb4 (path: /usr/share/mysql/charsets/)

The host is running php 5.6.31. They are not upgrading to php 7 until March 2018. I do have access to the cpanel - in phpMyAdmin it shows the following:

  • Server connection collation: utf8_general_ci
  • Server charset: UTF-8 Unicode (utf8)
  • PHP extension: mysqli 

I converted back to the previous working version until I could get some advice on this error. 

Thank you!  Tina

will do! thank you! 

By ht1080z - December 21, 2017 - edited: December 21, 2017

Hi Dave,

I'm getting the same:
mysqli: error setting character set utf8mb4: Can't initialize character set utf8mb4 (path: /usr/share/mysql/charsets/)

upgrading from 3.06 to 3.12? Is there any solution yet?

MySQL v5.5.52
PHP Version 5.6.29

Thanks,
Karls

Hi Karlz, 

It's a default part of MySQL 5.5 so it should be supported.  I've attached a test script.  Just set your mysql details at the top of the script.  You can find them in your /data/settings file.

Can you let me know the output and what your host says?  Also, who is your host?  I'm wondering if it's the same host.

Dave Edis - Senior Developer
interactivetools.com
Attachments:

_utf8mb4_bug_demo.php 4K

Hi Dave,

I cannot connect to the mysql with only localhost, username and password but without db name, I'm getting Failed to connect to MySQL: (1045)
Thanks,
Karls

Hmm, can you email me FTP details and an URL to the test script to dave@interactivetools.com and I can take a look for you?  Note: Don't post login details to the forum.  Thanks!

Dave Edis - Senior Developer
interactivetools.com