4 posts by 3 authors in: Forums > CMS Builder
Last Post: November 29, 2017   (RSS)

I currently have CMS Builder version 2.61 and I am requesting the last version before 3.xx because I do not have php 5.6 installed on my server as yet.

Can this be sent to my email please?

Send an email to support@interactivetools.com and we can get that sent out to you.

Thanks!

---------------------------------------------------
Cheers,
Damon Edis
interactivetools.com

Hire me! Save time by getting our experts to help with your project.
http://www.interactivetools.com/consulting/

Can you tell me if version 2.61 can run properly with the latest versions of php and mysql without any issues?

Will I have to do anything to the coding or CMS if I upgrade to php 5.6?

I wish to upgrade to version 3.xx but I want to make sure that there will not be any issues with my current version and php 5.6.

Hi wevolutions, 

The "latest" version of PHP is 7.1 and has removed the mysql library so you need to upgrade to CMSB v3.09+ to support that.

That "oldest" official PHP version is 5.6 and I believe CMSB v2.65 should work fine with that, but PHP 5.6 was actually released about 5 months after CMSB v2.65.

You can see the current PHP versions here: http://php.net/supported-versions.php

The process I would recommend is: 

  • Backup and upgrade to CMSB 2.65
  • Then upgrade to PHP 5.6

Hope that helps!

Dave Edis - Senior Developer
interactivetools.com