5 posts by 2 authors in: Forums > CMS Builder
Last Post: September 26, 2017   (RSS)

Has anyone come across the error message "This connection is not secure" while trying to login to CMSB before? My client is getting this when she tries to login using Firefox on her Mac.

I googled the error, and this work around came up: https://www.ghacks.net/2017/06/13/firefox-disable-this-connection-is-not-secure-warnings/

Hi CommonSenseDesign, 

Is it a secure https:// url?  All the browsers are starting to get updated to show warnings for non-https sites.  The solution is to switch the site over to https.

Dave Edis - Senior Developer

Thanks for the reply, Dave.

Do you think it's necessary and/or advisable for a non-eCommerce site to switch to https from http? This is just a basic brochure site, without any secure information.

No, I don't think it's necessary, but it will produce those warnings.  So you could advise the client to either ignore them, configure their browser to not display them, or offer them the (billable) option to upgrade the site to https and get them an ssl certificate.

This page seems to indicate how to disable the warnings for Firefox: 

Hope that helps!

Dave Edis - Senior Developer