7 posts by 3 authors in: Forums > CMS Builder
Last Post: July 5, 2017   (RSS)

I'm trying to do my first site with 3.09.  When i try to use the Image icon and upload an image, I click on the upload button next to Image URL and a new window pops up with the same window


2017-06-29_14-45-55.png 55K

Hi Gary,

From the screenshot, it looks like the WYSIWYG editor is displaying an older version.

Here some steps to take:

  1. Reupload the CMS Builder 3.09 files.
  2. Clear the cache in your browser.
  3. Add the advanced tab back into the new version of CMS Builder:

Let me know if these steps make the new insert image dialog box appear.


Damon Edis

Hire me! Save time by getting our experts to help with your project.

I figured out what was going on here...I was still using a TinyMCE 3 add-in.  Oops. 

Anyway, now that I have my settings setup for TinyMCE 4, I cannot get two VERY important things to occur...

1) I use custom font sizes:

    fontsize_formats: "8px,9px,10px,11px,12px,13px,14px,15px,16px,17px,18px,19px,20px,21px,22px,23px,24px,26px,30px,36px,0.2em,0.4em,0.6em,0.8em,1.0em,1.2em,1.4em,1.6em,1.8em,2.0em,2.4em,2.8em,3.0em",

The default font sizes of 8pt 10pt 12pt, etc. are just not good enough.  I've seen this work elsewhere on StackOverflow so I don't know why this is not working for me.  I've tried single quotes, double quotes, spaces in between, commas in between, all to no avail.  Any ideas would be welcomed.

2) I use a rather extensive set of external CSS that I'd like included in the editor - these are not showing up, so all of my styles are missing.

I usually just append my style sheet to the wysiwyg_custom.css so I end up with code that looks like this:

content_css: "/cmsAdmin/lib/wysiwyg_custom.css?1498662204,/design/custom/fonts.css?dt=1498769071,/design/custom/editor.css?dt=1498769071"

This has always worked in the past and I would get all of my custom styles in the styles dropdown.  I don't get any of my custom styles now.

Again, pointers would be appreciated.


One step closer - I found the importcss plugin - that imports the CSS from the included CSS files...now just the fonts...

This looks like a bug in the docs or the implementation that cmsb is using.  I scoured the tinymce.min.js file and found that the setting name needs to be fontsizeFormats, not fontsize_formats - After setting fontsizeFormats to my long string, it took no problem.

So, at least for now, it looks like I'm over the hump on my issues with TM4.


Thanks Gary, 

Nice catch, it looks like they fixed the fontsize_formats bug in a recent update: 

Version 4.6.1 - May 10, 2017
FIXED bug where fontsize_formats option had been renamed incorrectly.

Ref: https://www.tinymce.com/docs/changelog/#version461-may102017

I'll update tinymce for the next CMSB release.  In the meantime you could just list both for compatability: 

// fontsizeselect options - reference: https://www.tinymce.com/docs/configure/content-formatting/#fontsize_formats
fontsize_formats: '8pt 10pt 12pt 14pt 18pt 24pt 36pt',
fontsizeFormats:  '8pt 10pt 12pt 14pt 18pt 24pt 36pt', // for tinymce < 4.6.1


Dave Edis - Senior Developer