Login | Sign up | Toll-Free: 1-800-752-0455
 
 

Forum

 

7 posts by 3 authors in: Forums > CMS Builder: Plugins & Add-ons
Last Post: June 29, 2017

Hi again,

I am trying to setup my plugins as usual for my new installation of v.3.09 but I am having troubles activating the  Create Record Here and Permalink plugin.

When I activate the Create Record Here plugin it gives me an error page when pressing the Save button. The Apply button and Save and Copy button does not give me this error.

MySQL Error: Access denied for user 'studiohart'@'localhost' (using password: NO)

The error log:

E_WARNING: mysql_query(): A link to the server could not be established
/xxx/cmsb/plugins/createRecordHere_1_01/createRecordHere.php (line 46)
https://xxx/cmsb/admin.php?menu=blog&saved=7

The same error page appears when I activate the Permalink plugin (v.1.05 & 1.07).

They work fine on 3.07 and I've checked my database information on data.settings.php. I haven't tried 3.08.

Please tell me how I can solve this problem. 

Thank you!

Hiroko

Hi Hiroko,

Can you try enabling this option: Admin > General Settings > Advanced Settings > Legacy MySQL Support

And let me know if that resolves the issue? 

Dave Edis - Senior Developer
interactivetools.com

Hi Jeff, 

Can you try with the latest Permalinks plugin (v1.08 released May 28th): 
https://www.interactivetools.com/add-ons/permalinks/

It's been updated for PHP 8 and mysqli.

Let me know if that works for you.

Dave Edis - Senior Developer
interactivetools.com

permalinks is fine - the only error is create here

------------
Jeff Shields

Hi Jeff, 

Ok, no worries.  I've updated the "Create Record Here" plugin for PHP 7 and mysqli.  You can download it here:
https://www.interactivetools.com/add-ons/create-record-here/

Hope that helps!

Dave Edis - Senior Developer
interactivetools.com

Sorry I haven't replied and thank you for the update.

It is all working now. Thank you!