3 posts by 2 authors in: Forums > CMS Builder
Last Post: June 21, 2017   (RSS)

By icttech - June 20, 2017 - edited: June 20, 2017


After uploading CMS Builder to our test server area and trying to run from http://domain.com/cmsb/ we get the following error which redirects to admin.php

errorlog_enable: error_reporting() must be set to -1, not 32759!

The following has also been disabled.

  1. php.ini.disabled
  2. .htaccess.disabled
  3. .user.ini.disabled

PHP version 5.6.30 with all extensions required.

Also tried: PHP 7.0

A module for PHP applications that use MySQL databases

  • php70-php-mysqlnd Installed 7.0.20-1.1.4.cpanel

We get the following error: This program requires the PHP 'mysql' extension.

MySQL extension is installed what can be causing this?

Also how can I tell which version is being installed and where are the error logs being generated?



By Dave - June 21, 2017

Hi icttech,

Can you make sure you're using the latest v3.10 version of CMSB?  The 'mysql' library stop being required a few versions ago (we use mysqli now).  You can download the latest version here: https://www.interactivetools.com/order/download.php

Next, if you still get the error_reporting() error, here's what's happening.  We set error_reporting(-1) in /lib/init.php so that the CMS can capture and log all errors.  That error you're getting is one that should never happen. The error logging library is reporting that error reporting isn't what it was expecting it to be set to.  My first guess is either your PHP configuration isn't letting you set error_reporting() or you've got a CMS plugin or another script changing it in the middle of CMSB starting up.

Here's a quick script you can test to confirm you can set error_reporting() on your server: 

<?php // test_error_reporting.php
print "<h1>Test setting error_reporting()</h1>\n";
print "<li>error_reporting() returns: " . error_reporting(). "\n";
print "<li>setting error_reporting(-1)\n"; error_reporting(-1);
print "<li>error_reporting() returns: " . error_reporting(). "\n"; // expecting -1

Can you let me know if installing v3.10 fixes it and/or the output of the script?


Dave Edis - Senior Developer