Increase length of Upload Info Fields

4 posts by 2 authors in: Forums > CMS Builder
Last Post: June 1, 2017   (RSS)

By Dave - May 25, 2017

Hi theclicklab, 

First, make a backup of your CMS database under the backup and restore menu before making any changes.

Then, the uploads table is hidden in the "Section Editors" list but you can edit it by typing in the table name directly like this: 

Modify info1, info2, etc and at the bottom under "Advanced Options" set "MySQL Column Type" to MEDIUMTEXT

Let me know if that works for you.  

Dave Edis - Senior Developer

By theclicklab - May 25, 2017

Hi Dave, I did that but the actual field in the upload popup also has a maxlength on it as well. I also tried changing the field type to text box but this still shows as a text field. 

By Dave - June 1, 2017

Hi TheClickLab, 

Hmm, it looks like the way the CMS is hardcoded doesn't really support what you want to do.

If you want to manually edit the files and remove that maxlength setting you can find it in this file:

And search for maxlength then you can remove that attribute.

However, any custom custom changes you make will get overwritten when you upgrade the CMS so what we recommend if you do that is to create a file in the CMS folder called _CUSTOM_CHANGES_.txt and just make a note of the changes you've made and what files you changed them in.  This way anyone who upgrades the CMS will notice that file, and even if they don't it will be an easy reference to how to recreate any custom changes.

Hope that helps, let me know if you need anything else.

Dave Edis - Senior Developer