CMSB v3.01 Released - Maintenance Release - Jan 20th, 2016

6 posts by 3 authors in: Forums > CMS Builder
Last Post: January 28, 2016   (RSS)

  • Archived  

By Dave - January 20, 2016

Hi All,

We've just released v3.01 (Build 2057) which a number of minor bug fixes and tweaks for the 3.0x branch.

If you haven't upgraded to version 3 yet you can read all about that here: 
http://www.interactivetools.com/forum/forum-posts.php?CMSB-v3.00-Released---Responsive-UI---Jan-8th-2016-80341

To see the full list of changes, please visit the CMS Builder changelog: http://www.interactivetools.com/tour/changelog.php
and CMS Builder users can upgrade by donation at this page: http://www.interactivetools.com/upgrade/

Here's the complete changelog for v3.01

*** January 20, 2016 - Version 3.01 (Maintenance Release)

SERVER REQUIREMENTS:
- This software version requires: PHP 5.4.0+ and MySQL 5.0+
- Future versions will require: PHP 5.5.0+ and MySQL 5.5+
- NOTE: Some plugin may need to be updated when upgrading from v2.xx to v3.00

MINOR CHANGES
- Developers: New plugin hooks: getLastNumberInUrl_removeFields
- Added resize cursor on hover to drag sort icon
- Install screen password field no longer displays entered characters (password field instead of text field)

BUG FIXES
- Upgrade code now defaults to "theme_blue.css" if a non-existant theme is specified
- Fixed default settings file to use "theme_blue.css" instead of invalid "theme_classic.css"
- Fixed "how to install.txt" to list to correct PHP version required: v5.4+
- Fixed double htmlencoding on CMS home dashboard page which caused single quotes to appear as '
- Fixed issue that prevented some errors and menu notices from displaying correctly
- Fixed issue that caused menu items to sometimes display twice
- Fixed issue where clicking search button wouldn't show count of matching records
- Misc Code and other minor improvements

Please feel free to post your feedback and questions.  Thanks!

Dave Edis - Senior Developer
interactivetools.com
  • Archived  

By wolf66 - January 26, 2016

Hi there, 

I have just upgraded from 2.16 to this release due to my host provider upgrading PHP to 5.6 which caused CMS B 2.16 to display hundreds of lines of deprecation errors similar to this: 

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /var/www/vhosts/alfdkalsdfjdslafj.com.au/public_html/cmsb/lib/common.php on line 159

After updating to 3.01 the public pages have returned to a normal display however attempting to access cmsb/admin.php brings up : 

MySQL Error: Table '358409_cmsbuilder.cms__error_log' doesn't exist

This isn't mentioned as a potential problem with upgrading to 3.01 from 2.16 anywhere I can find in the upgrade notes or here on the forums. That table didn't exist prior to this upgrade in the MySQL db and hasn't been created as part of the upgrade... unsure how to fix.

Any assistance would be appreciated. Having a live site return hundreds of errors was bad enough. Would like to restore full functionality ASAP. 

  • Archived  

By Dave - January 26, 2016

Hi wolf66, 

Double check that you've uploaded this file from the upgrade zip: data/schema/_error_log.ini.php

And if that doesn't work feel free to email CMS & FTP login details directly to dave@interactivetools.com (don't post login details to the forum) and I'll take a look for you ASAP.

Thanks!

Dave Edis - Senior Developer
interactivetools.com
  • Archived  

By Toledoh - January 28, 2016

Just noticed that the "View Website" link now opens in the same window - can you add target="_blank" as previous version?

Cheers,

Tim (toledoh.com.au)
  • Archived  

By Dave - January 28, 2016

Thanks Tim, I've fixed that for the next release.

Dave Edis - Senior Developer
interactivetools.com