• Archived  

By Joseph - March 23, 2010 - edited: March 23, 2010

HI, AM has been working fine for a long while now but i am now getting a file lock error. Error: SERVERBUSY: Timed out waiting for a filelock

What can i do to resolve this?


Re: [socanews] File Lock Error

  • Archived  

By Donna - March 23, 2010

Hi there!

Check your file permissions -- that's usually caused by Article Manager not being able to write, modify or remove the filelock.lock file in the /data/ directory. The /data/ directory and all of the files within should have full 777 permissions.

You can also try deleting the filelock.lock file so that Article Manager can recreate it (and should then be able to modify it.)


Re: [Donna] File Lock Error

  • Archived  

By Joseph - March 24, 2010

Thanks for that Donna, this is really weird..

I first followed your instructions but couldn't even find the filelock file under the data folder, so i left it with te intention to reply to your post informing of the missing file. aboutn hour later I then tried AM and the issue seemed to have resolved itself and i was able to log in.

Before writing this message i tried logging into AM again and got the same error - Error: SERVERBUSY: Timed out waiting for a filelock