• Archived  

By peterachel - February 3, 2010

When trying to post a new article, Summary and Content WYSIWYG boxes not showing up using Article Manager 2 brand new installations - IE8, IE7 (the boxes show up on Firefox but do not support WYSIWYG). Is this a browser or server permissions issue? I'm trying to get to the bottom of this issue and get these installations working properly.

Re: [peterachel] Summary and Content WYSIWYG boxes not showing upan

  • Archived  

By MikeB - February 3, 2010

Hi Peter,

I've looked at the few installation requests we've had from you recently and I can't see which site this is taking place on. Have you managed to resolve this since posting this?

If not, just let me know which site it was and I'll see if I can track down your install request. If not, I may need to grab login details for Article Manager from you so I can test this out myself.

I look forward to hearing from you Peter! [:)]

Mike Briggs - Product Specialist

<hr /><i><a href="http://www.interactivetools.com/consulting/" rel="nofollow"><b>Hire me!</b></a>
Save time by getting our experts to help with your project. Template changes, advanced features, full integration, whatever you need. Whether you need one hour or fifty, get it done fast with <a href="http://www.interactivetools.com/consulting/" rel="nofollow"><b>Priority Consulting</b></a>.</i>

Re: [MikeB] Summary and Content WYSIWYG boxes not showing upan

  • Archived  

By BillG - March 6, 2010 - edited: March 6, 2010

I had this same problem - I had to cancel, then re-enter the article editing mode in order to get the WYSIWYG boxes to show up.

I had briefly looked at this earlier and this is a JavaScript race condition between scripts being loaded asynchronously.

The text box field calls the WYSIWYG editor, BUT the JavaScript script file for the WYSIWYG editor hasn't finished loading yet! So, the page is calling the function to load the WYSIWYG editor, but the function isn't completely loaded because the included JavaScript file with the function hasn't finished loading! It takes an advanced understanding of browser mechanics and the differences between the new JavaScript engines to debug this problem.

When the page is re-loaded, the JavaScript for the editor is usually in the browser cache so the WYSIWYG is finally displayed. But it's dependent upon the type and version of the browser, the browser's settings, and the speed of the server.

Firefox 3.5 is best behaved with this. IE and the latest Chrome are the worst.

There's a text page you can use to examine the behavior here:

The page also tests the "defer" attribute. You can test a browser, reload it, then test again and see how the behavior changes.

I fixed this with a template mod to _wrapper.html, if IT will allow me to post the fix I'll be happy to share.

Re: [BillG] Summary and Content WYSIWYG boxes not showing upan

  • Archived  

By Donna - March 10, 2010

Hi Bill,

Sure, feel free to send over your fix. :)


Re: [BillG] Summary and Content WYSIWYG boxes not showing upan

  • Archived  

By mbittner - March 18, 2010

In the _wrapper.html Admin template, look for the line

<script type="text/javascript" src="$_weburl$javascript/loadWysiwyg.js" language="JavaScript1.2" onerror="errorLoadingScript(this)"></script>

On the default _wrapper.html, it's at Line 89.

Delete that line, and instead insert it at Line 56 so you now see:

<script type="text/javascript" src="$_weburl$javascript/loadWysiwyg.js" language="JavaScript1.2" onerror="errorLoadingScript(this)"></script>

This loads the WYSIWYG earlier, so when the function is called, it is (hopefully) always loaded.

This is NOT a good technical fix because it only works 90% of the time. I don't know enough about JavaScript to come up with a permanent fix. It is, after all, a race condition, and if someone at IT cares enough they can come up with a permanent fix.

<chuckle> Sure hope that's true, and IT can figure out a permanent fix. I've been battling this one for quite some time. I plan on applying your patch soon, and will keep my fingers crossed that it will all work out - somehow - in the end.
Matt Bittner
Software Engineer
Internet Modeler

_wrapper.html replacement

  • Archived  

By BillG - March 18, 2010

Attached is my _wrapper.html (see below)

This goes in your

directory. Rename your present _wrapper.html to _wrapper.old before replacing it with this one!

It contains the WYSIWYG mod.

It also adds a JavaScript link at the upper-right to switch the present page between SSL and non-SSL.

I make no warranties yada yada, but I welcome any feedback or suggestions!

_wrapper_001.html 8K

Re: [BillG] _wrapper.html replacement

  • Archived  

By Donna - March 18, 2010

Oddly enough, I can't reproduce the problem at all in any browser, so this is a bit perplexing. I've passed it around to some of the programmers to take a look at and see if they can reproduce it. :)


Re: [Donna] _wrapper.html replacement

  • Archived  

By BillG - March 19, 2010

Race conditions are a pain in the youknowwhat...

You can attempt reproducing the problem this way - on a FAST, DUAL-PROCESSOR computer:

1. Log into the AM main screen using IE8.
2. Clear the IE browser cache
3. Click Create Article

I'm a hardware guy so I think hardware, and a dual-processor computer (like an Intel Core Duo) might distribute the browser code asynchronously. The fact that my fix works most of the time proves that it is a JavaScript loading problem.

Re: [BillG] _wrapper.html replacement

  • Archived  

By Donna - March 22, 2010

Hey Bill (and others having this problem), just wanted to doublecheck -- are you using the TinyMCE patch for Article Manager, or the old default Innova editor?