Here's what I've done:

- Created 2 categories
- Created 1 article
- Assigned this 1 article to each of the 2 categories I created
- Created 2 "a page for each article" publishing rules - each with a unique "Placeholder Set Name", unique Filename (eg: "<artFile>" AND "<artFile>_suffix") and assigned to each of the 2 categories via the 'Category Filter' control
- Created 2 "a list of articles" publishing rules - each with a unique "Placeholder Set Name", unique Filename and assigned to each of the 2 categories via the 'Category Filter' control

So, I end up with the 1 article I created being published 2 times (eg: "articlenameForCat1" and "articlenameForCat2"). This is good.

I also end up 2 published article lists - one for each "as list of articles" rules. This is also good.

The problem is that one of the published article lists has the correct URL for each article, but the 2nd published article list does not.

What seems to be happening is that when I assign an article to 2 categories, only the first category I assign it to is honored. In the 2nd published article list, the URL for each article only includes the "_suffix" in the URL, not the "<artFile>_suffix".

For instance, the 1 article that I created might have a filename as:

article_one

This would mean that, based on my publishing rules, the URL should be as follows for the 1st and 2nd published article lists, respectively:

article_one
article_one_suffix


However, this article shows up in the 1st published article list with a URL of:

article_one.html (this is a good thing)

...but in the 2nd published article list is has a URL of:

_suffix.html (this is a bad thing)


For some reason, only the first list of articles publishing rule is fully publishing the URL.

I'm doing this because I'm redesigning a site and want to keep the main articles in tact, but assign them to 2 categories - 1 which is the category within the existing site and the other category which exists for the newly designed site. This way, I can keep the content in tact and just pull new includes into the new site without effecting the existing site (essentially, using this for staging).

Please help!

Thanks,

Aaron

Re: [zakcoop] Adding article to more than one category breaks Placeholder Set Name in list of articles template

Since only the unique "_suffix" is being published for items in the 2nd list of article publishing rule, it seems like the <artFile> isn't getting populated in the second list of articles publishing rule.

I'm using "_ba" as the suffix (see screenshot). Am I declaring this "Published Files" name incorrectly? Only the "_ba" suffix is getting published in the URL.
Attachments:

picture-1_006.png 69K

Re: [zakcoop] Adding article to more than one category breaks Placeholder Set Name in list of articles template

Hi Zak,

In your second template, what do you have set as the HTML for the "link" to the new article?

By default, you should have:

<a href="$published.articlePage.url$">

...however, if you've changed the Article Page placeholder (in the "a page for each article" publish rule), you'll need to update that to match in your second category list placeholder.

For example, if you changed the placeholder to articlePage2, the code would be:

<a href="$published.articlePage2.url$">

Does that make sense? Give that a try and let me know if that works for you. :)
Donna

--
support@interactivetools.com

Re: [Donna] Adding article to more than one category breaks Placeholder Set Name in list of articles template

Correct, I have the following:

<a href="$published.newsDetailPageba.url$">$article.title$</a>

I added the "ba" suffix to differentiate this from the other template which uses:

<a href="$published.newsDetailPage.url$">$article.title$</a>


Any other thoughts?

I'll email you credentials for logging into our installation of Article Manager so you can get any details you need to troubleshoot this.

Thanks so much for being so prompt. I'm hoping to finish up some development this weekend and this is a stumbling block.

I've purchased many Article Manager licenses and, more recently, CMS Builder licenses, and I love your products.

Aaron

Re: [zakcoop] Adding article to more than one category breaks Placeholder Set Name in list of articles template

Hi Aaron!

I've replied to your email, hopefully we can get this sorted out pretty fast. :)
Donna

--
support@interactivetools.com

Re: [zakcoop] Adding article to more than one category breaks Placeholder Set Name in list of articles template

By marys - November 3, 2009 - edited: November 3, 2009

Please expand on this. I am having this exact problem.

I don't understand "...Make sure that your publish rule is publishing for the primary category set, and you shouldn't run into this."

Re: [marys] Adding article to more than one category breaks Placeholder Set Name in list of articles template

Hi Mary,

Are you using the feature that allows you to publish to multiple categories?
Donna

--
support@interactivetools.com

Re: [Donna] Adding article to more than one category breaks Placeholder Set Name in list of articles template

Yes.

The only way I've gotten it to work is to select ALL categories (meaning Site1 and Site2 categories) in the category filter for the Site2 Article Page Publishing rule.

This one install of AM2 is complicated. :-( Site1 pages are open to the public. Most of Site2 pages are not.

It's working now but has, for some reason, caused a SSI include error for the mouse trail on the Site2 shared articles.

The site went live at 5 p.m. EST. I've looked at the code much too long today, so I'll get back to troubleshooting tomorrow.