• Archived  

By Kimber - October 21, 2009 - edited: October 21, 2009

Hi

At http://www.momsbreak.com/printable/index.shtml I notice when I hit the << prev page it always take me back to the opening page instead of the page I just left.

A good example section is http://www.momsbreak.com/printable/babyshower/index.shtml I go the next page fine then when I go hit prev page I get [unknown placeholder $category.name$] for the title of the page.

Any idea what would cause this?

Thanks
Kimberly

Re: [Kimber] << prev page problem

  • Archived  

By Donna - October 22, 2009

Hi Kimber,

It looks like the "Prev" code has been changed to drop the category number in your categoryIndex Next & Prev buttons.

The important bit there is going to be: "&categoryNum=$category.num$"

The default code should be:

Previous:

<a href="$settings.searchurl$?action=search&amp;page=$articleList.prevPageNumber$&amp;perpage=$articleList.perpage$&amp;template=$articleList.template$&amp;includeSubcats=$articleList.includeSubcats$&amp;categoryNum=$category.num$">&lt;&lt; prev page</a>


Next:
<a href="$settings.searchurl$?action=search&amp;page=$articleList.nextPageNumber$&amp;perpage=$articleList.perpage$&amp;template=$articleList.template$&amp;includeSubcats=$articleList.includeSubcats$&amp;categoryNum=$category.num$">next page &gt;&gt;</a>


This usually happens if you used the Next & Prev code from the global index page, since of course there's no category number on those links.

I hope this helps. :)
Donna

--
support@interactivetools.com