Re: [zakcoop] Adding article to more than one category breaks Placeholder Set Name in list of articles template

  • Archived  

By zakcoop - October 20, 2009

Since only the unique "_suffix" is being published for items in the 2nd list of article publishing rule, it seems like the <artFile> isn't getting populated in the second list of articles publishing rule.

I'm using "_ba" as the suffix (see screenshot). Am I declaring this "Published Files" name incorrectly? Only the "_ba" suffix is getting published in the URL.
Attachments:

picture-1_006.png 69K

Re: [zakcoop] Adding article to more than one category breaks Placeholder Set Name in list of articles template

  • Archived  

By Donna - October 22, 2009

Hi Zak,

In your second template, what do you have set as the HTML for the "link" to the new article?

By default, you should have:

<a href="$published.articlePage.url$">

...however, if you've changed the Article Page placeholder (in the "a page for each article" publish rule), you'll need to update that to match in your second category list placeholder.

For example, if you changed the placeholder to articlePage2, the code would be:

<a href="$published.articlePage2.url$">

Does that make sense? Give that a try and let me know if that works for you. :)
Donna

--
support@interactivetools.com

Re: [Donna] Adding article to more than one category breaks Placeholder Set Name in list of articles template

  • Archived  

By zakcoop - October 23, 2009

Correct, I have the following:

<a href="$published.newsDetailPageba.url$">$article.title$</a>

I added the "ba" suffix to differentiate this from the other template which uses:

<a href="$published.newsDetailPage.url$">$article.title$</a>


Any other thoughts?

I'll email you credentials for logging into our installation of Article Manager so you can get any details you need to troubleshoot this.

Thanks so much for being so prompt. I'm hoping to finish up some development this weekend and this is a stumbling block.

I've purchased many Article Manager licenses and, more recently, CMS Builder licenses, and I love your products.

Aaron

Re: [zakcoop] Adding article to more than one category breaks Placeholder Set Name in list of articles template

  • Archived  

By Donna - October 23, 2009

Hi Aaron!

I've replied to your email, hopefully we can get this sorted out pretty fast. :)
Donna

--
support@interactivetools.com

Re: [Donna] Adding article to more than one category breaks Placeholder Set Name in list of articles template

  • Archived  

By zakcoop - November 2, 2009

Just wanted to follow up with a post showing the interactivetools.com support response that ultimately solved my problem:

.......

The way Article Manager handles multiple-category articles is by assigning a "primary" category. In all of the articles that are being published without the link, the "primary" category is: The Buzz : The Buzz - The Latest News

So... Article Manager is trying to link to the article created for that category. But that article doesn't exist with that publish rule, and so it comes back with nothing.

To test this out, I added "The Buzz" category mentioned to the "Latest News Detail Pages (BA)" publish rule, and republished both the articles & the associated index, and the links now work.

Basically, make sure that your publish rule is publishing for the primary category set, and you shouldn't run into this.

......

Re: [zakcoop] Adding article to more than one category breaks Placeholder Set Name in list of articles template

  • Archived  

By marys - November 3, 2009 - edited: November 3, 2009

Please expand on this. I am having this exact problem.

I don't understand "...Make sure that your publish rule is publishing for the primary category set, and you shouldn't run into this."

Re: [marys] Adding article to more than one category breaks Placeholder Set Name in list of articles template

  • Archived  

By Donna - November 3, 2009

Hi Mary,

Are you using the feature that allows you to publish to multiple categories?
Donna

--
support@interactivetools.com

Re: [Donna] Adding article to more than one category breaks Placeholder Set Name in list of articles template

  • Archived  

By marys - November 3, 2009

Yes.

The only way I've gotten it to work is to select ALL categories (meaning Site1 and Site2 categories) in the category filter for the Site2 Article Page Publishing rule.

This one install of AM2 is complicated. :-( Site1 pages are open to the public. Most of Site2 pages are not.

It's working now but has, for some reason, caused a SSI include error for the mouse trail on the Site2 shared articles.

The site went live at 5 p.m. EST. I've looked at the code much too long today, so I'll get back to troubleshooting tomorrow.