• Archived  

By terryally - September 30, 2008 - edited: September 30, 2008

Hi,

I have just installed Artman2 and want to use the backend database. I set up the database but Artman2 keeps telling me:


Program was unable to connect to the MySQL database 'lakedarts_content' on 'localhost:/tmp/mysql5.sock'.
The reason given was: Access denied for user: 'onlineu@localhost' (Using password: YES)


which is puzzling because all parameters are correct. Using the username and password, for example, I can log into phpmyadmin.

I decided then to change the host to use a remote connection (which I am not crazy about) and then it works. The remote connection is the URL for the database.

My question is why would Artman2 not want to accept that my host is localhost:/tmp/mysql5.sock?

Terry

P.S. The host connection syntax is correct.

Re: [terryally] Problem with MySQL connection

  • Archived  

By Donna - September 30, 2008

Hi Terry!

It sounds like Article Manager is able to connect to the database, but either the user name or password are not correct -- the error message it's giving back is related to the userid, not the database connection.

The username & password you use to access it via phpMyAdmin may not be the same one required for the database itself, so you'll want to doublecheck that.

I hope this helps!
Donna

--
support@interactivetools.com

Re: [Donna] Problem with MySQL connection

  • Archived  

By terryally - October 1, 2008

Hi Donna,

Sorry, this doesn't help.

The password is correct.
The username is correct.
The username and password to connect the database is the same used to access phpmyAdmin.

Article Manager is not able to connect to the database using localhost connection only remote connection.

Question is why?

The username and password for both localhost and remote are the same.

It is not an issue with username and password.

Is there any other reason why the localhost connection would not work? Does ArticleManager have some built in feature that does not recognise the syntax: localhost:/tmp/mysql5.sock ? That is my initial thought.

I want to revert to using localhost.

Hope you can help.
Terry

Re: [terryally] Problem with MySQL connection

  • Archived  

By Donna - October 1, 2008

Hi Terry,

Is there a specific reason you need to use that syntax, instead of the remote connection that you mentioned? If it's able to connect with the remote hostname, why not just use that?
Donna

--
support@interactivetools.com

Re: [terryally] Problem with MySQL connection

  • Archived  

By Donna - October 3, 2008

Hi Terry,

Well, "localhost" on its own should definitely work, the vast majority of Article Manager installations use "localhost" with no socket specified. Having to use the syntax you've mentioned with the socket specified is pretty unusual -- I've never come across a server that requires that, and I've done literally hundreds of Article Manager installations. So, if it doesn't work the only other option would be to edit the connect code directly in the module.

Take a look in the /modules/IT/DB/MySQL.pm module, that'll have the code that connects to the database.

I hope this helps. :)
Donna

--
support@interactivetools.com

Re: [Donna] Problem with MySQL connection

  • Archived  

By terryally - October 4, 2008

Hi Donna,

I've had a look.

Localhost won't work (for my server) without modifying some of your application routines which I won't do (for many practical reasons).

In addition to that the files do state: "Warning : Modifying this program violates your license agreement!"

So I shall leave it as it is and use the remote connection.

Terry