5 posts by 2 authors in: Forums > CMS Builder
Last Post: December 26, 2012   (RSS)

I am looking for instructions for use of the database restore feature located in the admin general settings (CMSB version 2.50). I thought it would be as easy as selecting the database version to restore and clicking the 'restore' button. What resulted is a new set of errors in CMSB admin relating to a field name that did not exist at the time of the backup.

I only chose to restore the backup database, because I renamed a field which caused a glitch within CMSB that would not allow me to update the associated editors relating to that field. I simiply could not get there. I've renamed fields in other versions of CMSB, then can update any records relating to that field, but not in this case.

Should I have done something other than select the backup database to roll back? It appears I'll have to start over again with this build and data entry, but I would like to know for future reference.

Thanks for any help.
~ Deborah

 

 

 

By Dave - December 21, 2012

Hi Deborah, 

Are you trying to merge some new data and fields you've created since the backup or just restore the backup?  

Generally you need everything to match up, so the /data/schema/ folder (or the fields under the field editor) should be the same as when the backup was made).

If you are getting errors because there is a field in the schema (created in the field editor) that doesn't exist in the MySQL Database you can just click on "Section Editors" and it will automatically check and re-create any fields that are missing from the MySQL.

What are the specific errors and where are they appearing?  

Let me know and I'll try help.  Thanks!

Dave Edis - Senior Developer
interactivetools.com

HI, Dave.

After renaming a table I was seeing error messages when viewing associated section editors from the nav menu. I don't recall if I clicked on 'Section Editors' or not.

This isn't a live site, so at that time I chose to restore a database backup from earlier that day. After restoring the backup I saw errors referring to a newer section editor that didn't exist in the old database.

I've just renamed an editor to see what would happen. The error message "Warning: Cannot modify header information - headers already sent..." appeared if I simply through the navigation menu to that editor. I think that is the same error I saw originally. Clicking on 'Section Editors' gives me access to update the associated editors. I think that may be what happened on the first round. (I should have taken screen captures.)

I've worked through everything and am back where I need to be now. I'll be sure to click the 'Section Editor' link in the future if I have to rename anything.

Thanks for your prompt assistance and instrucitons.

Deborah

By Dave - December 24, 2012

Hi Deborah,

Ok, do you still need a hand with it?  If so, feel free to email the details to dave@interactivetools.com and I can take a look for you.

Note: Email, don't post login details to the forum.

Thanks!

Dave Edis - Senior Developer
interactivetools.com