5 posts by 2 authors in: Forums > CMS Builder
Last Post: May 17, 2012   (RSS)

By InHouse - May 16, 2012

Hi,

We've recently launched a site which uses a (horrible) plug-in to display proprietary file types in the browser. At first, only a single file type was supported, but as of a recent software update, that format has been deprecated. The plug-in supports both formats.

However, the client is storing these small files on the server. They arrive via a fairly standard CMSB 'upload' field in an editor. These files are stored in <domain>cmsAdmin/uploads/scortch/ .

The page that displays these files works well with the legacy .sco files. However, it balks when the new .sib format is uploaded to the default directory. If the .sib files are manually stored elsewhere, they work well.

For example:
/cmsAdmin/uploads/scortch/myfile.sco
works great.

/cmsAdmin/uploads/scortch/myfile.sib
fails to load in the plug-in (and crashed the plug-in)

/test/myfile.sib
works great.

I don't see anyting in the CMSB .htacces file that might trigger this behaviour. It's repeatable any number of ways.

Any ideas why that file type in that directory might fail to be served?

Thanks,
Jayme

Re: [InHouse] Accessing Uploaded Files Issue

By Dave - May 16, 2012

Hi Jayme,

That's really odd. I'm not sure what could be causing that.

What happens when you manually upload a sib file to the cmsAdmin upload folder, eg: /cmsAdmin/uploads/scortch/myfile2.sib

Or when you manually upload a sib file to a nearly identically named folder, eg: /cmsAdmin2/uploads/scortch/myfile2.sib

Let me know and I'll post if I can think of anything else.
Dave Edis - Senior Developer
interactivetools.com

Re: [Dave] Accessing Uploaded Files Issue

By InHouse - May 17, 2012

Hi Dave,

Actually, after the first upload failed to work I started doing manual FTP uploads to the various other locations being tested.

Your question reminded me that using the CMSB uploader, the file was about 10% lighter when posted then what I had on my local drive. That's one of the reasons why I then posted items manually after that.

I'll try the 'nearly identical' option and let you know.

J.

Re: [InHouse] Accessing Uploaded Files Issue

By Dave - May 17, 2012

Ok, glad it's working now. Let me know if anything crops up again in future.

Cheers!
Dave Edis - Senior Developer
interactivetools.com