13 posts by 3 authors in: Forums > CMS Builder
Last Post: January 18, 2012   (RSS)

By Jason - January 16, 2012

Hi,

If smaller files are working, it definitely sounds like a timeout issue. Even if the server is configured to allow for an upload of 1Gb, the time it takes to physically upload a file that size would most likely be longer than the maximum script execution time.

Do you have a number of large files that need to be uploaded trough CMS Builder? Another option would be to upload the files through FTP and then in each record, store a path to the file.

Hope this helps
---------------------------------------------------
Jason Sauchuk - Project Manager
interactivetools.com

Hire me! Save time by getting our experts to help with your project.
http://www.interactivetools.com/consulting/

By Jason - January 18, 2012

Hi,

We starting looking into this further, and this could also be an issue with the max file size limit on the server. We can attempt to override this by using the PHP ini_set function.

If you go into cmsAdmin/lib/init.php.

Near the top, you'll see a number of ini_set calls. Add these two:

ini_set('display_errors', '1'); //
ini_set('display_startup_errors', '1'); //
ini_set('track_errors', '1'); // store last error in $php_errormsg
ini_set('html_errors', '0'); // don't output html links in error messages
ini_set('mysql.trace_mode', '0'); // when this is enabled SQL_CALC_FOUND_ROWS and FOUND_ROWS doesn't work: http://bugs.php.net/bug.php?id=33021

ini_set('upload_max_filesize', '150M');
ini_set('post_max_size', '150M');


You can replace 150M with whichever number you need. Please note that this is a custom change and will be overwritten if you upgrade your version of CMSB

Give this a try and let us know what you find.

Thanks.
---------------------------------------------------
Jason Sauchuk - Project Manager
interactivetools.com

Hire me! Save time by getting our experts to help with your project.
http://www.interactivetools.com/consulting/