By craigh - November 4, 2011

Hi there,

I have acquired a client that is using Article Manager from a web design firm. I looked for a version number, but the only clue I have is the "artman2" in the URL, leading me to believe it's version 2.

The issue is not a WYSIWYG one, references to which I have found on here.

Rather, when trying to create an article, the drop-down list of categories does not display when using Internet Explorer 9. Instead all that is displayed is "loading list", according to the client, although from viewing the HTML source it's actually probably "Loading category list...". The user cannot "add another category" either. Because, apparently, a category is required when creating a new article, the user cannot save or preview a new article.

I have not seen this for myself, as my machines run Windows XP and IE 9 is only available for Vista (I think) and Windows 7.

This is all the information I have on this issue at the moment, so if anyone has follow-up questions I will need to consult the client or find a machine with MSIE 9. However, the problem is not apparent in IE 8 or Firefox 7.0.1, and only started to exhibit itself when the client upgraded from IE 8 to IE 9.

Anyone have any ideas to address this issue? Thanks.


Craig

Re: [craigh] Article Manager Issue with IE9

By BillG - November 17, 2011 - edited: November 17, 2011

To see your version, log into AM and go to Admin > General Settings. Look for a line that says "Program Version".

To get around IE9 problems, if you are using v2+ go to the following directory:
\cgi-bin\artman2\templates\admin\menus
You need to edit the file _wrapper.html.

Open that file and look for the <head> tag.
After <head>, insert this:
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7">

It is important that the above line must be immediately after the <head> tag or it won't work. It cannot be after the <title> tag, it must be immediately after the <head> tag.

(note that you can choose either EmulateIE7 or EmulateIE8).

That should fix your problem with IE9 compatibility.

Let me know how it works out.


Note: If you cannot find _wrapper.html, then you are using an earlier version of AM. Let me know and I'll see if I can find the proper file for you to edit.

Re: [BillG] Article Manager Issue with IE9

By craigh - November 17, 2011

Hi BillG,

Thanks very much for your reply.

To see your version, log into AM and go to Admin > General Settings. Look for a line that says "Program Version".


Maybe the log-in information I've been given isn't for admin, but I don't see an "Admin" menu option anywhere. I'll have to check with the web design company.

Note: If you cannot find _wrapper.html, then you are using an earlier version of AM. Let me know and I'll see if I can find the proper file for you to edit.


I have it. However, I haven't managed to establish contact with this client yet, so I'll wait until I do before I change anything. I did suggest that they try IE's compatibility mode to see if that helped but, as I say, I haven't heard back from them yet.

Will post here again when I know what the solution is. Thanks again.


Craig

Re: [craigh] Article Manager Issue with IE9

By BillG - November 17, 2011

Glad I could help!

The thing about setting IE's compatibility mode is that it's only for that particular browser. Using the META tag makes it more universal. It's still not an optimal solution. I'm using Win XP so I'm still using IE8 myself. I have no issues with Firefox.

It sounds like they haven't given you the Admin password. Do you have FTP access?