35 posts by 6 authors in: Forums > CMS Builder
Last Post: December 15, 2011   (RSS)

Our Demo was working fine until we added the "Display Demo Notice" plugin.

Now we get quite a few Undefined index errors. (Even when we removed the plugin and reset the demo mode to "0", the errors still persist.)

Notice: Undefined index: wysiwygLang in /home/demo/lib/wysiwyg.php on line 20
Notice: Undefined index: includeDomainInLinks in /home/demo/lib/wysiwyg.php on line 32
Notice: Undefined index: wysiwygLang in /home/demo/lib/wysiwyg.php on line 53
Notice: Undefined index: wysiwygLang in /home/demo/lib/wysiwyg.php on line 54
Notice: Undefined index: wysiwygLang in /home/demo/lib/wysiwyg.php on line 54

Thanks,

Chris

Re: [Christopherb] Beta Testers: New "Public Demo Mode" feature

By Dave - May 11, 2010

Hi Chris,

I'd recommend upgrading or making sure you have these values in your /data/settings.dat.php:

[wysiwyg]
includeDomainInLinks = 0
wysiwygLang = "en"

Hope that helps!
Dave Edis - Senior Developer
interactivetools.com
Hi Dave,

Just before I received your post, I reverted back to an old "settings.dat.php" file and added the plugin manually. Now everything works.

Using CMS Builder 2.02.

Thanks,

Chris

Re: [Christopherb] Beta Testers: New "Public Demo Mode" feature

By Dave - May 11, 2010

Yea, it sounds like it was just missing some settings values.

Glad to hear it's working again. All the best! :)
Dave Edis - Senior Developer
interactivetools.com
OK, now we have a new problem.

We upgraded to 2.04 and now receive the error:

Creating demo (please wait a moment)...
Error: Couldn't create demo after 12 attempts! Please contact us and let us know about this error!

Any ideas?

Re: [Christopherb] Beta Testers: New "Public Demo Mode" feature

By Dave - September 14, 2010

Hi Christopherb,

My first guess would be that you might be out of disk space on your database server. But if you can email me your FTP and CMS login details to dave@interactivetools.com I can take a look for you. Also include a link to this post.

Note: Email, don't post login details to the forum.

Hope that helps!
Dave Edis - Senior Developer
interactivetools.com

Re: [terryally] Beta Testers: New "Public Demo Mode" feature

By Dave - November 10, 2011

Hi Terry,

Yes, you can just put it into demo mode, you don't need a second copy. Whatever content you have in the system will be the default content all new users see. If a "demo user" changes the content then only they will see those changes.

Hope that helps!
Dave Edis - Senior Developer
interactivetools.com

By Djulia - December 13, 2011

Hi Dave,

Are the temporary tables removed automatically?

Thanks!

Djulia

Re: [Djulia] Beta Testers: New "Public Demo Mode" feature

By Dave - December 13, 2011

Hi Djulia,

Yes, they are. Old demos are cleaned up each time a new demo is created. Here's some details on how it works if you're curious:

It's all hard-coded but the max demo time is set in /lib/init.php:
define('MAX_DEMO_TIME', 60*60*1); // 1 hour

And the following two functions in /lib/common.php create and remove demos:
setupDemoIfNeeded()
_removeOldDemos();

Hope that helps!
Dave Edis - Senior Developer
interactivetools.com