Login | Sign up | Toll-Free: 1-800-752-0455
 
 

Forum

 

11 posts by 4 authors in: Forums > CMS Builder
Last Post: July 15, 2008

Re: [dwelling] Uploads failing

Hi Jeremy,

Yep, sounds like it's timing out -- even if your host has no set timeout, HTTP just wasn't designed for uploading really large files like that. FTP is probably the route to go there.

As for having it linked in CMS Builder, one option would be to create a new field for the filenames and type them in there... then add the link code to your page (like this: <a href="<?php code goes here?>">Download Audio File</a>)

With that, whatever you put into the field will be output for that field (with the correct PHP code from the code generator for that field, of course.)

Would something like that work for you?
Donna

--
support@interactivetools.com

Re: [dwelling] Uploads failing

Jeremy,

Is the user on high-speed or dialup? If you wanted to send me (FTP Login, CMS Login, and a sample file that times out) to dave@interactivetools.com I could take a look at your settings to see if anything could be adjusted.

Hope that helps!
Dave Edis - Senior Developer
interactivetools.com

Re: [Dave] Uploads failing

Thanks so much Dave (and Donna). I'm sending over an email now.

Jeremy
---------------------------
Dwelling Productions
www.dwellingproductions.com

Re: [dwelling] Uploads failing

By dwellingproductions - July 8, 2008 - edited: July 8, 2008

Problem solved! Thanks Dave!

Just in case anyone has this problem in the future, here's what fixed it. The following is an email I received from Dave:

"Hi Jeremy,

If you look under Admin > General > phpinfo (a link at the bottom)
http://www.yourdomain.com/cmsAdmin/admin.php?menu=admin&action=phpinfo

It lists all the PHP config options. Here's some that will make it timeout

max_execution_time (program run time) was set to 60, I updated in your /php5.ini to be 300
max_input_time (upload time) was set to 30, I updated in your /php5.ini to be 300 (five minutes)
post_max_size (upload size) was set to 8M, I updated in your /php5.ini to be 100M
upload_max_filesize (max upload size) was set to 2M, I updated in your /php5.ini to be 100M

After changing those it seems to work. Can you test it on your end?

Hope that helps!"



The changes were made to the PHP5.ini file located in the root directory of the site (if running PHP 5). (If this file does not exist, you can make one by creating a text file, saving it as "php5.ini" - if running PHP version 5 - and putting the following lines in the file.) Dave added these lines to the php5.ini file:

max_input_time = 300
post_max_size = "100M"
max_execution_time = 300
upload_max_filesize = "100M"


Everything now works perfectly! Thanks again!

Jeremy
---------------------------
Dwelling Productions
www.dwellingproductions.com

Re: [dwelling] Uploads failing

Hi - I'm having the same issue here - any pdf over about 3 meg just fails to upload. But I don't have the phpinfo link that you describe in your Admin settings?

I am using CMS version 1.07 - is it time to upgrade? :-)

thanks

Jim

Re: [jimbly2] Uploads failing

Hi Jim,

You can create your own info script. Just create a new file called phpinfo.php with this contents:

<?php print phpinfo(); ?>

Hope that helps!
Dave Edis - Senior Developer
interactivetools.com

Re: [Dave] Uploads failing

Hi Dave,

hope you're well - yes thanks - I remembered that just after I posted! I need to get access to the server root to revise the php.ini file now.

Re: [jimbly2] Uploads failing

Ok, keep in mind that different hosts are setup differently. Sometimes you can set those settings with an .htaccess file, sometimes they'll be in your website root in a /php.ini (beside your index.html), and sometimes you'll need to ask your host to make the changes.

If unsure, just check with your host.
Dave Edis - Senior Developer
interactivetools.com

Re: [Dave] Uploads failing

Hi Dave,



I've made changes to the php.ini file, but do I need to restart the webserver for the changes to take effect?



thanks

J