Login | Sign up | Toll-Free: 1-800-752-0455
 
 

Forum

 

5 posts by 3 authors in: Forums > CMS Builder
Last Post: December 1, 2007

Hi -
Having just downloaded CMS builder I was disappointed to see it requires MySQL 5.0.24 to run (missed that on the specs).

Is that an absolute necessity or a recommendation? (ie is there any point in me trying to install it with MySql 4.1.22? 5.x seems quite a high requirement (my hosting company doesn't have any servers on that version yet) and though they're happy to upgrade me I'm a bit worried it will break other stuff.

Regards, Steve.

Re: [steve_e] MySql 5

No, it does need MySQL 5.0.24 or better.

The MySQL company recommends version 5 and has version 6 in alpha. And there is a real push on to get everybody up to MySQL 5 and PHP 5 lately so we decided to start with the more recent versions rather than have to convert 6 months in.

The biggest thing is that MySQL 5 has more strict error reporting. So if you get new errors with your old scripts you need to add "SET SESSION sql_mode=''" to their code to turn off the new errors. Most big hosts will do this automatically for you anyways.

If you get stuck anywhere in the process feel free to post. We had a few hickups in our server upgrade and may be able to help.
Dave Edis - Senior Developer
interactivetools.com

Re: [Dave] MySql 5

By osluk - November 30, 2007 - edited: November 30, 2007

It has really good precise error messages: This program requires MySQL v5.0.24 or newer. This server has v5.0.15 installed. Please ask your server administrator to install MySQL v5.0.24 or newer.

Just heard back from the sys admins

> At this moment v5.0.24 or newer is not available, we'll update in future but its not
> possible to let you know the exact time.

Wow from one extreme to another.

Looks like this version's requirments are hardly supported anywhere.

Still looking to find any of our existing suppliers or servers which meet the requirements.

Upgrading is such a big issue - PHP and or MySql seem to enevitably stop functioning on perfectly good stable installations.

Why withdrawn perfectly good stable universally compatible products and roll out bleeding edge products with very limited support and worse still if you can install CMS 1.1 you can bet most of the legacy apps will not survive the scores of PHP MySql issues.

Looking forward to seeing it working!

Why are there not online demos as there are for the other products? Hosting compatibility?!

Cheers Chris
_______________________
Chris from Optima
"please always add logical keywords to help find items"

Optima Solutions Limited
http://www.osl.net
"technology for business"
Nominet member for .UK names and European hosting

Re: [osluk] MySql 5

I know how frustrating it can be trying to upgrade things on your server. I've gone through it many times on my own development server and with many web hosts.

If you're upgraded to MySQL 5.0.15 now then you should probably be fine with that one. I'd give it a try. Here's how to bypass the version check:

- Edit the file /cmsAdmin/lib/database_functions.php
- Search for "$requiredVersionAsString" (around line 123)
- Change the version from '5.0.24' to '5.0.15'
- Run the program again.

Let me know how that works out.
Dave Edis - Senior Developer
interactivetools.com