CMSB v3.54 Released - October 29, 2020

27 posts by 9 authors in: Forums > CMS Builder
Last Post: February 23, 2021   (RSS)

  • Archived  

By Codee - December 1, 2020

Hey Dave,

A patch is needed, please - where is the necessary file and line. Thank you kindly.

CMSB v3.54 Released - October 29, 2020

  • Archived  

By pault - December 2, 2020

Hi Dave,

I've just tried ping localhost and it returns so it's odd but guess it's got something to do with the MySQL setup.

I've commented that line out which is fine for me but if you can think of a fix for the next release then it will avoid me having to remember to apply the patch.

Thanks, Paul.

  • Archived  

By Dave - December 2, 2020

Hi Equinox

To hide the mysql version warning search this file: /lib/menus/admin/general.php

For "nextMySqlRequired" to find this line: 

$nextMySqlRequired = '5.5'; // to support utf8mb4 :

And change it from 5.6 to 5.5.

Let me know if that works for you.

Dave Edis - Senior Developer
  • Archived  

By Codee - December 2, 2020 - edited: December 2, 2020

Mr. Dave,

Worked perfectly.  Thank you kindly! I hope you, your staff and families have a wonderful holiday season ~ full of hope, love and joy!

Thank you.

Media Library

  • Archived  

By AlanAlonso - December 16, 2020 - edited: December 16, 2020

After I update to 3.54 the image uploads don't show thumbnails and the link to the images are generated as /media instead of /uploads
I have Media Library disabled

Media Library

  • Archived  

By AlanAlonso - December 16, 2020

I moved all files from /upload to /media and changed directories on Upload Directory and Upload Folder URL, also downloaded the uploads table and delete /home/user/... to just leave filename and it's working all again.

CMSB v3.54 Released - October 29, 2020

  • Archived  

By rez - February 23, 2021 - edited: February 23, 2021

I have media library items that I can't delete. Trying to delete entries gives me a notice that I cannot remove items in use. I don't believe they are in use. Maybe I changed the name of the editor? CMSB seems to be looking for an editor named screen that does not exist. The end result is that I can't remove these entries. I was able to  remove a photo in one of the media library entry modification details. You can see the first item does not have a photo. I was still not able to remove the item from the media library.

Screenshots show the 3 steps I tried showing a warning.: Modify>Used by> Warning

The other notification is when selecting erase on a media library item:  "You can't erase media if it's currently in use."

Please advise.

Edit: I'm sure I did add those photos in a content wysiwyg when I was testing this first media library installation. However, I dont have these content boxes anymore with photos in them. I'm guessing after the time I created them, I changed the editor name then deleted the records using them, breaking the link of where CMSB believes the records are in use. - Something like that! Maybe I'm way off on a solution or the actual issue but I don't want to poke around (trying to re-create the "screen" editor to delete for instance) and break everything I have working. I'm not comfortable at the moment going into cpanel and deleting records... maybe if I'm not going to break everything ?   


it-ml.jpg 194K