Login | Sign up | Toll-Free: 1-800-752-0455
 
 

Forum

 

3 posts by 2 authors in: Forums > CMS Builder
Last Post: September 2, 2017

Hello! 

I'm currently using v3.08 (build 2120) and everything was working perfectly then image upload method (what happens after you click "Add or Upload File(s)" changed on Chrome - the browser I have been using consistently for quite some time. 

It started with the client having their portrait images turned horizontal, but I believe we got that sorted out by re-saving the jpgs then reloading to eliminate anything that came from the camera. Then her Chrome browser started showing the old image upload method too. Where you have to browse for each image individually instead of being able to upload multiple images in a few clicks. (Screenshot included.)

Firefox 55.0.3 on Mac & Windows works fine - as expected. 
Chrome 60 on Mac/Win, Edge on PC and Safari 10.1.2 all gave the "old style screen" with individual browse buttons as show in screenshot

Any suggestions? 

Thanks! Tina

Hi, Tina.

It sounds like possibly one of two things (or both).

1) Make sure that on the CMS Builder 'General Settings' page under 'Advanced Settings' that 'Disable Flash Uploader' is NOT checked.

2) A Chrome browser update might have disabled the Flash plugin required for the multiple upload functionality. You can read how to enable the plugin here:
https://support.google.com/chrome/answer/6258784

As for the images being turned, that's a result of how some devices and cameras set the 'EXIF orientation flag' when saving the digital image. It's not always apparent when viewing the images on the device or even on a PC how they'll upload in advance.

I've not tried this myself, but see in CMS Builder an experimental option you might want to try if your client has a lot of rotated images. Looks like you'd toggle 'false' to 'true' where shown below. If you don't get out-of-memory errors, maybe that will work for you.

(from /lib/upload_functions.php, around line 225 in v3.08):

// [experimental] rotate uploaded JPEG file if EXIF Orientation flag has been set
// explanation: certain cameras save rotated JPEG content and use a poorly-supported EXIF flag to tell users the image must be rotated (90, -90, or 180)
// our resampling code, which relies on GD, doesn't respect or preserve that flag, which can result in certain uploaded files being saved with incorrect rotation
// in testing, doing rotations like the following before resampling caused out-of-memory errors on reasonably large image files, so this fix has been disabled by default
$fixJpegExifOrientation = false; // defaulted to false to avoid potential out-of-memory errors

Hope that helps you.
~ Deborah

Thanks Deborah! 

1) Flash uploader was enabled in CMS

2) I had just installed flash to see if that was the issue, BUT, I had not gone to Chrome Settings. It was set to "Allow sites to run Flash" AND "Ask First". I turned off "Ask First" and that did the trick! 

Thanks for the info on the other image issue! 

Have a great weekend! Tina