By rez - January 15, 2018 - edited: January 15, 2018

Notice: Undefined variable: partial match line 143

same for line 147

fatal error: setPrefixedCookie: Can't set cookie (loginsession #) headers already sent!

geocoder.php output started line 143, common.php line 706

Getting the above error pop-up when saving a record of a location. The Latitude and Longitude are not being auto filled by the plugin.

My API key is working /The example map in the plugin installation Admin screen is working. GEOCODER_USE_PARTIAL_MATCHES is set to "true".

I dont get this pop-up every time but the Long and Lat are never filled. I made sure all other tabs are closed since it mentioned some cookie situation but i have no idea how to proceed. Please advise.

Version: 1.06 with the latest cmsb


Hi Rez, 

Thanks for reporting this.  Can you try changing line 142 from this: 

$isPartialMatch = @$response['results'][0]['partial_match']; 

To this:

$partialMatch = @$response['results'][0]['partial_match']; 

And let me know if that resolves the issue for you?

Dave Edis - Senior Developer

By rez - January 18, 2018 - edited: January 18, 2018

Hi Dave,

I was sidetracked by another project. I have made the change you suggested. I'm not seeing the error but the longitude and latitude still aren't being filled in when i save a new record or re-save a previous one.

The names of my 2 text fields match the geocoder.php file. 'latitude' and 'longitude'. I also have address, city, state, and zipcode text fields filled in.

These are restaurant locations. I always copy a working schema ini file from a latest working site and use it as a schemaPreset on a new site. So that preset, multi list, locations.ini.php was from CMSB v3.08 (Build 2120). I'm not sure if this is helpful. 

Hi rez, 

Can you try setting this to true at the top of your plugin? 


If that doesn't work, send me an email to with CMS/FTP login details and steps to recreate the issue and I can take a look.  Note: Don't post login details to the forum.


Dave Edis - Senior Developer

No luck. Email sent. Thanks!