Login | Sign up | Toll-Free: 1-800-752-0455
 
 

Forum

 

6 posts by 3 authors in: Forums > CMS Builder
Last Post: October 25, 2017

When you create a new section that has the 'Date' field defined, it is setting the maximum date to 2015 when you try and add a record you can't until you fix the constraint.

Larry

---
<? Larry >
Coding since 1973

Hey, jenolan.

I'm not seeing a predetermined max date when creating a new date field... in ver 3.10 or even back to ver 2.61. What I see is shown in attached screenshot.

Could you be working with an older install where you need to manually enter the years range?

A screenshot of what you're seeing would be of help.

~ Deborah

Attachments:

dates.jpg 75K

Nope current version, use 'news' preset and you should see it.

Larry

---
<? Larry >
Coding since 1973

Hi,

I see that too. To fix, open /data/schemaPresets/news.ini.php.

In the date array, change this:

'yearRangeStart' => '2008',
'yearRangeEnd' => '2016',

To this:

'yearRangeStart' => '',
'yearRangeEnd' => '',

This will allow you to use the current date. 

I have sent this over to Dave to get added to the CMS Builder next build.

Thanks!

---------------------------------------------------
Cheers,
Damon Edis
interactivetools.com

Hire me! Save time by getting our experts to help with your project.
http://www.interactivetools.com/consulting/

Okay, didn't know you were using a preset.

For me the version 3.10 'News' preset shows a default 2008 to 2016. That's just an example range.You can either expand that year range when creating the new section or you can edit the master 'news.ini.php' template. The year start or end can be whatever you set.

[date]

order = 8
label = "Date"
type = "date"
isUnique = 0
showTime = 0
showSeconds = 0
use24HourFormat = 0
yearRangeStart = 2008
yearRangeEnd = 2016

~ Deborah

By Damon - October 25, 2017 - edited: October 25, 2017

Hi again,

Just an update that for the Date field, the yearRangeStart and yearRangeEnd have been updated in the next version of CMS Builder (3.11) to be blank in both the schema presets for News and Blog.

Thanks for finding and noting this!

---------------------------------------------------
Cheers,
Damon Edis
interactivetools.com

Hire me! Save time by getting our experts to help with your project.
http://www.interactivetools.com/consulting/