• Archived  

By doitnow - January 25, 2010

After a fresh install of AM2 (and a upgrade patch for the editor) - that worked fine - changed the db type from file to sql - (have an existing AM2 db) - everything looks great in categories, users, etc.

Get the following error message when attempting to view the articles.
Error: DBD::mysql::st execute failed: Unknown column 'featured' in 'field list' at /home/abundant/public_html/cgi-bin/artman2/modules//IT/DB/MySQL.pm line 376.

Check the db table article and their is a featured column in the table structure. Suggestions? Or should I just backup the db - then drop the column see if it work then re-add the column.

Thx

Re: [doitnow] AM2 - error when accessing AM2 - MSQL DB

  • Archived  

By doitnow - January 25, 2010

Ok - new information.

When creating a new tables through db editor - new prefix. get the following error when saving - the application is attempting to create all the tables

Error: unknown field type ''! at /home/abundant/public_html/cgi-bin/artman2/modules//IT/DB/Common.pm line 775.

ran Mysql test on db - everything checks ok

Re: [doitnow] AM2 - error when accessing AM2 - MSQL DB

  • Archived  

By doitnow - January 25, 2010

well at least the error is consistent - when attempting to move the existing tables (data) to a new schema get this error:

Error: DBD::mysql::st execute failed: Unknown column 'featured' in 'field list' at /home/abundant/public_html/cgi-bin/artman2/modules//IT/DB/MySQL.pm line 376.

Re: [doitnow] AM2 - error when accessing AM2 - MSQL DB

  • Archived  

By doitnow - January 25, 2010

not able to delete the column from table editor even though it showed as their. Could not modify or delete the column from within table editor. Backdoor added a column in the right place. Now I can at least delete the column and it is gone correctly. Re-added the column through the table editor - now have same error as originally but new column.

I will attempt to walk through all the different "missing" columns - I have saved off a copy of all the data so if necessary I can drop a column recreate it and then populate through the backend (insert into x values (select x from temp table)

this may or may not work?

Re: [doitnow] AM2 - error when accessing AM2 - MSQL DB

  • Archived  

By doitnow - January 25, 2010

ok found out was missing four columns (how that happened unknown) - and I can not populate them as the hold table was missing them anyway. Will have to work through that.

Added columns via backend -
drop column via table editor
add column back via table editor

everything is back - so far so good. All articles their (of courswe missing some data from the missing columns)

Off to other issues

Re: [doitnow] AM2 - error when accessing AM2 - MSQL DB

  • Archived  

By Donna - January 25, 2010

Hi there,

Glad to hear you got that sorted out! If you're still having problems with it, feel free to fill out a support request and we can pop in and see what's going on in there. :)
Donna

--
support@interactivetools.com

Re: [Donna] AM2 - error when accessing AM2 - MSQL DB

  • Archived  

By doitnow - January 27, 2010

Donna - still getting problems with the tables - I have opened a ticket at your suggestion. Ticket ID (ATB-113131) Thx

Re: [doitnow] AM2 - error when accessing AM2 - MSQL DB

  • Archived  

By Donna - January 28, 2010

Sounds great, we'll take a look at that ASAP. :)
Donna

--
support@interactivetools.com